aboutsummaryrefslogtreecommitdiffstats
path: root/testing/git2json/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/git2json/APKBUILD')
-rw-r--r--testing/git2json/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/testing/git2json/APKBUILD b/testing/git2json/APKBUILD
index 5b91c7bfd3a..a4bf4131111 100644
--- a/testing/git2json/APKBUILD
+++ b/testing/git2json/APKBUILD
@@ -1,23 +1,28 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=git2json
pkgver=0.2.3
-pkgrel=3
+pkgrel=8
pkgdesc="Convert git logs to JSON for easier analysis"
url="https://github.com/tarmstrong/git2json"
arch="noarch"
license="BSD-3-Clause"
-depends="python3"
-makedepends="py3-setuptools"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/g/git2json/git2json-$pkgver.tar.gz"
-
+options="!check" # no tests included
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="3bac219c79b25a4e0e41c250214131911a7e207c1908a81316eab546df538e03dda2446f8c74a337f502deacf61c61cc76062f85f2313d29d3b6c5059447582d git2json-0.2.3.tar.gz"
+sha512sums="
+3bac219c79b25a4e0e41c250214131911a7e207c1908a81316eab546df538e03dda2446f8c74a337f502deacf61c61cc76062f85f2313d29d3b6c5059447582d git2json-0.2.3.tar.gz
+"