aboutsummaryrefslogtreecommitdiffstats
path: root/testing/glmark2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/glmark2/APKBUILD')
-rw-r--r--testing/glmark2/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/glmark2/APKBUILD b/testing/glmark2/APKBUILD
new file mode 100644
index 00000000000..49ac8656419
--- /dev/null
+++ b/testing/glmark2/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Danct12 <danct12@disroot.org>
+# Maintainer: Danct12 <danct12@disroot.org>
+pkgname=glmark2
+pkgver=2020.04
+pkgrel=0
+pkgdesc="OpenGL 2.0 and ES 2.0 benchmark"
+url="https://github.com/glmark2/glmark2"
+arch="all"
+license="GPL-3.0-or-later"
+subpackages="$pkgname-doc"
+makedepends="python3 eudev-dev libjpeg-turbo-dev libpng-dev mesa-dev wayland-dev wayland-protocols"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/glmark2/glmark2/archive/$pkgver.tar.gz
+ py3-compat.patch
+ "
+options="!check" # no testsuite
+
+prepare() {
+ default_prepare
+ python3 ./waf configure --prefix=/usr --with-flavors drm-gl,drm-glesv2,wayland-gl,wayland-glesv2,x11-gl,x11-glesv2
+}
+
+build() {
+ python3 ./waf
+}
+
+package() {
+ python3 ./waf install --destdir="$pkgdir"
+}
+
+sha512sums="68d72403ab5c6b4562faf43ae94159e4b8dcb697f62ea9dc3eac5634a3e22b19e14e215a081ae2a39e5db77e6f0f40d5ceb0281962600526d08121a197105a80 glmark2-2020.04.tar.gz
+f03c39b1bc26d3a38a54f1cf029d4714d502e4f4be8e89a9a86aa116c16f07226714f73e00e99eab9529f20532d47a734f9ebab71bc02d7829a986c91f3f2dab py3-compat.patch"