aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-session/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gnome-session/APKBUILD')
-rw-r--r--testing/gnome-session/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/gnome-session/APKBUILD b/testing/gnome-session/APKBUILD
new file mode 100644
index 00000000000..63b421e00cd
--- /dev/null
+++ b/testing/gnome-session/APKBUILD
@@ -0,0 +1,38 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=gnome-session
+pkgver=3.24.1
+pkgrel=0
+pkgdesc="GNOME session manager"
+url="http://www.gnome.org/"
+arch="all"
+license="GPL"
+depends="gnome-shell"
+depends_dev=""
+makedepends="gnome-settings-daemon-dev libsm-dev itstool libxslt libxml2-utils"
+install=""
+subpackages="$pkgname-doc $pkgname-lang"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-session/${pkgver%.*}/gnome-session-$pkgver.tar.xz
+ fail-whale-dialog.patch
+ no-rpmatch.patch"
+builddir="$srcdir/gnome-session-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="507f9f1cddab37f1b66c72291e1885397f7e8b6bfb7c365f6f1ff827649a71380706fe0e3a8c6e74c3c159349a0eea0aabe3d5c7bbae5b29aeb2d49ae715affb gnome-session-3.24.1.tar.xz
+0a5dd181c060a8d403b26b3d3b647b6cc7c519b487a05a2f11693fdbb9f61257e4e433c989c835cf1210bc199a92e9d5418b7de9a2a248b595b679f3c1c2b9b5 fail-whale-dialog.patch
+0d6057cc47f3494050cf02f55b887ae0fea2b405fe3585b412f91c79dafaab77a4d3da2d77fa65bd43a7a9a77b83c11e78f68af659378f3f62f857ca1a86c6de no-rpmatch.patch"