aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gnome-session/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gnome-session/APKBUILD')
-rw-r--r--testing/gnome-session/APKBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/testing/gnome-session/APKBUILD b/testing/gnome-session/APKBUILD
index 60f375d8228..11c68e23dc0 100644
--- a/testing/gnome-session/APKBUILD
+++ b/testing/gnome-session/APKBUILD
@@ -1,20 +1,18 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=gnome-session
-pkgver=3.24.1
-pkgrel=2
+pkgver=3.26.0
+pkgrel=0
pkgdesc="GNOME session manager"
url="http://www.gnome.org/"
arch="all !aarch64 !armhf"
license="GPL"
depends="gnome-shell"
-depends_dev=""
-makedepends="gnome-settings-daemon-dev libsm-dev consolekit2-dev itstool libxslt libxml2-utils json-glib-dev"
-install=""
+makedepends="gnome-settings-daemon-dev libsm-dev
+ consolekit2-dev itstool libxslt libxml2-utils json-glib-dev"
subpackages="$pkgname-doc $pkgname-lang"
-source="http://ftp.gnome.org/pub/GNOME/sources/gnome-session/${pkgver%.*}/gnome-session-$pkgver.tar.xz
- fail-whale-dialog.patch
+source="http://ftp.gnome.org/pub/GNOME/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
no-rpmatch.patch"
-builddir="$srcdir/gnome-session-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -30,11 +28,15 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="507f9f1cddab37f1b66c72291e1885397f7e8b6bfb7c365f6f1ff827649a71380706fe0e3a8c6e74c3c159349a0eea0aabe3d5c7bbae5b29aeb2d49ae715affb gnome-session-3.24.1.tar.xz
-0a5dd181c060a8d403b26b3d3b647b6cc7c519b487a05a2f11693fdbb9f61257e4e433c989c835cf1210bc199a92e9d5418b7de9a2a248b595b679f3c1c2b9b5 fail-whale-dialog.patch
+sha512sums="05ba2465dee4b23d4cf758c15b7a682207fbc50039d95a60c37051cfa31707dc6737bcbf809812b429cb7ce03bf340d30e66916a579677586b3e531c862a6819 gnome-session-3.26.0.tar.xz
0d6057cc47f3494050cf02f55b887ae0fea2b405fe3585b412f91c79dafaab77a4d3da2d77fa65bd43a7a9a77b83c11e78f68af659378f3f62f857ca1a86c6de no-rpmatch.patch"