aboutsummaryrefslogtreecommitdiffstats
path: root/testing/go-mtpfs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/go-mtpfs/APKBUILD')
-rw-r--r--testing/go-mtpfs/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/go-mtpfs/APKBUILD b/testing/go-mtpfs/APKBUILD
index 6f81cd597d4..7874e81571e 100644
--- a/testing/go-mtpfs/APKBUILD
+++ b/testing/go-mtpfs/APKBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Dekedro <dekedro@tankers.xyz>
+# Maintainer: Dekedro <dekedro@protonmail.com>
pkgname=go-mtpfs
pkgver=1.0.0
-pkgrel=1
+pkgrel=19
pkgdesc="Mount MTP devices over FUSE"
url="https://github.com/hanwen/go-mtpfs"
arch="all"
@@ -10,6 +10,10 @@ makedepends="go libusb-dev"
options="net !check" # tests require MTP device to be connected
source="$pkgname-$pkgver.tar.gz::https://github.com/hanwen/go-mtpfs/archive/refs/tags/v$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
go build
}