aboutsummaryrefslogtreecommitdiffstats
path: root/testing/goimapnotify/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/goimapnotify/APKBUILD')
-rw-r--r--testing/goimapnotify/APKBUILD40
1 files changed, 0 insertions, 40 deletions
diff --git a/testing/goimapnotify/APKBUILD b/testing/goimapnotify/APKBUILD
deleted file mode 100644
index 55cacb01e11..00000000000
--- a/testing/goimapnotify/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Clayton Craft <clayton@craftyguy.net>
-# Maintainer: Clayton Craft <clayton@craftyguy.net>
-pkgname=goimapnotify
-pkgver=2.3.2
-pkgrel=0
-pkgdesc="execute scripts on IMAP mailbox changes using IDLE, golang version"
-url="https://gitlab.com/shackra/goimapnotify"
-arch="all"
-license="GPL-3.0-or-later"
-makedepends="go"
-options="net"
-source="https://gitlab.com/shackra/goimapnotify/-/archive/$pkgver/goimapnotify-$pkgver.tar.gz"
-
-build() {
- export CGO_CPPFLAGS="$CPPFLAGS"
- export CGO_CFLAGS="$CFLAGS"
- export CGO_CXXFLAGS="$CXXFLAGS"
- export CGO_LDFLAGS="$LDFLAGS"
- export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-
- # Fix build on riscv64
- go mod edit -replace \
- golang.org/x/sys=golang.org/x/sys@v0.0.0-20210630005230-0f9fa26af87c
- go mod download golang.org/x/sys
-
- go build -ldflags "-linkmode=external -extldflags=$LDFLAGS"
-}
-
-check() {
- go test ./...
-}
-
-package() {
- install -Dm755 goimapnotify "$pkgdir"/usr/bin/goimapnotify
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
-}
-
-sha512sums="
-99b5822295700ebdc3a6a80cc5f4c515cb791a506fd6ba146ecd3b6bdcdfb084b61e9e25ae86fbf2d3992f39d928c028c6b144ef96e999bda53786f6e731b412 goimapnotify-2.3.2.tar.gz
-"