aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gopls/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gopls/APKBUILD')
-rw-r--r--testing/gopls/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/gopls/APKBUILD b/testing/gopls/APKBUILD
deleted file mode 100644
index fe104f15bfc..00000000000
--- a/testing/gopls/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: David Florness <david@florness.com>
-# Maintainer: David Florness <david@florness.com>
-pkgname=gopls
-pkgver=0.7.3
-pkgrel=1
-pkgdesc="Language server for Go programming language"
-url="https://github.com/golang/tools/blob/master/gopls"
-license="BSD-3-Clause"
-arch="all"
-options="chmod-clean"
-makedepends="go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/golang/tools/archive/gopls/v$pkgver.tar.gz"
-builddir="$srcdir/tools-$pkgname-v$pkgver/$pkgname"
-
-export GOPATH="$srcdir"
-
-check() {
- cd test
- go test
-}
-
-build() {
- go build -trimpath -o dist/gopls
-}
-
-package() {
- install -Dm755 dist/gopls "$pkgdir"/usr/bin/gopls
-}
-
-sha512sums="
-1f35e413ee7ef9146144154bed701ad6f8c86a59ee0be50b0ad0890602d5f2f0652a8c9e3909764c4b256aab2efddc33716867be156a0d05eb45ac7ded505591 gopls-0.7.3.tar.gz
-"