aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gops/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gops/APKBUILD')
-rw-r--r--testing/gops/APKBUILD30
1 files changed, 0 insertions, 30 deletions
diff --git a/testing/gops/APKBUILD b/testing/gops/APKBUILD
deleted file mode 100644
index 9710fe5c30a..00000000000
--- a/testing/gops/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Michał Polański <michal@polanski.me>
-# Maintainer: Michał Polański <michal@polanski.me>
-pkgname=gops
-pkgver=0.3.22
-pkgrel=1
-pkgdesc="List and diagnose Go processes currently running on your system"
-url="https://github.com/google/gops"
-license="BSD-3-Clause"
-arch="all"
-makedepends="go"
-source="https://github.com/google/gops/archive/v$pkgver/gops-$pkgver.tar.gz"
-
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -modcacherw"
-
-build() {
- go build -ldflags "-s -w" -v -o bin/$pkgname
-}
-
-check() {
- go test ./...
-}
-
-package() {
- install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
-}
-
-sha512sums="
-8e5e622dad925de1aa0f4afae8de0ff31e0e65042e84fadbcd4b0033a35f839dd8bc04c621307c74c9e5ca2e47403b4daaf694f06aeae958c2e19090d6621c40 gops-0.3.22.tar.gz
-"