aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gops/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gops/APKBUILD')
-rw-r--r--testing/gops/APKBUILD30
1 files changed, 0 insertions, 30 deletions
diff --git a/testing/gops/APKBUILD b/testing/gops/APKBUILD
deleted file mode 100644
index a5410aeadd2..00000000000
--- a/testing/gops/APKBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Contributor: Michał Polański <michal@polanski.me>
-# Maintainer: Michał Polański <michal@polanski.me>
-pkgname=gops
-pkgver=0.3.21
-pkgrel=0
-pkgdesc="List and diagnose Go processes currently running on your system"
-url="https://github.com/google/gops"
-license="BSD-3-Clause"
-arch="all"
-makedepends="go"
-source="https://github.com/google/gops/archive/v$pkgver/gops-$pkgver.tar.gz"
-
-export GOPATH="$srcdir"
-export GOFLAGS="$GOFLAGS -trimpath -modcacherw"
-
-build() {
- go build -ldflags "-s -w" -v -o bin/$pkgname
-}
-
-check() {
- go test ./...
-}
-
-package() {
- install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
-}
-
-sha512sums="
-c12fc48560ec12ac365c6d6a9aa80d7858939f1d90a76b6f37910b520c739645cc1b2ec79fe1de7c8931bd953face44fbdafe1ceae3206e182b6e6a6982df78c gops-0.3.21.tar.gz
-"