aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gosu/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gosu/APKBUILD')
-rw-r--r--testing/gosu/APKBUILD45
1 files changed, 13 insertions, 32 deletions
diff --git a/testing/gosu/APKBUILD b/testing/gosu/APKBUILD
index b6e291047c2..3142bfaa91e 100644
--- a/testing/gosu/APKBUILD
+++ b/testing/gosu/APKBUILD
@@ -1,47 +1,28 @@
# Contributor: David Huffman <storedbox@outlook.com>
# Maintainer: David Huffman <storedbox@outlook.com>
-
-_gosu_repo='github.com/tianon/gosu'
-_gosu_ver=1.12
-_gosu_src="gosu-$_gosu_ver"
-
-_runc_repo='github.com/opencontainers/runc'
-_runc_ver=1.0.0-rc91
-_runc_src="runc-$_runc_ver"
-
pkgname=gosu
-pkgver=$_gosu_ver
-pkgrel=1
+pkgver=1.17
+pkgrel=2
pkgdesc="Simple Go-based setuid+setgid+setgroups+exec"
url="https://github.com/tianon/gosu"
-arch="all !mips !mips64" # go is missing
-license="GPL-3.0-or-later"
+arch="all"
+license="Apache-2.0"
makedepends="coreutils go"
-source="https://github.com/tianon/gosu/archive/$_gosu_ver/$_gosu_src.tar.gz
- https://github.com/opencontainers/runc/archive/v$_runc_ver/$_runc_src.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tianon/gosu/archive/refs/tags/$pkgver.tar.gz"
options="!check" # require docker to run tests
-builddir="$srcdir"/$_gosu_repo
-prepare() {
- mkdir -p $_gosu_repo $_runc_repo
- mv -T $_gosu_src $_gosu_repo
- mv -T $_runc_src $_runc_repo
-
- default_prepare
-}
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
build() {
- CGO_ENABLED=0 \
- GOPATH="$startdir:$srcdir/$_runc_repo/Godeps/_workspace" \
- GO111MODULE=off \
- go build -v -ldflags '-s -w'
+ go build -v
}
package() {
- local bindir="$pkgdir/usr/bin"
- mkdir -p "$bindir"
- cp gosu "$bindir"
+ install -Dm755 gosu -t "$pkgdir"/usr/bin/
}
-sha512sums="3f8874ab3cefee3332d3a89541c395f7de3b5f758c7464f7a1cb5614ceb15ed69119bdc9628eb56a9d9830fe0f93bc72f36bce9669a3c0cc3dae9db4d677a7e3 gosu-1.12.tar.gz
-9e639c0de1b6bc414fc909c4342590e00d8473b06cfa6e38fa47eef0afb00e811f2b9a83913fb5ad0fa1691e88a9dd9d280367b4f8a9e4746a5c8b522d7ad74c runc-1.0.0-rc91.tar.gz"
+sha512sums="
+5a8bd7fce5c9080118dcf2c86332671441e133e44d08baea7dbc9f622e8d1bec1a229d3d7a38846bdcdcb66538222d5871e565e71eea1677fcd5727b836cdbce gosu-1.17.tar.gz
+"