aboutsummaryrefslogtreecommitdiffstats
path: root/testing/grpc-health-check/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/grpc-health-check/APKBUILD')
-rw-r--r--testing/grpc-health-check/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/testing/grpc-health-check/APKBUILD b/testing/grpc-health-check/APKBUILD
index 58729499a8c..1393a5e1b1d 100644
--- a/testing/grpc-health-check/APKBUILD
+++ b/testing/grpc-health-check/APKBUILD
@@ -1,30 +1,34 @@
-# Contributor:
# Maintainer: Build Robot <buildrobot@pay.pizza>
pkgname=grpc-health-check
-pkgver=0.1.0
-pkgrel=0
-arch="all !s390x !ppc64le !armhf !armv7 !mips64"
+pkgver=0.1.1
+pkgrel=3
+arch="all !s390x !ppc64le !armhf !armv7 !riscv64"
pkgdesc="gRPC health checking protocol"
url="https://github.com/paypizza/grpc-health-check"
license="Apache-2.0"
-makedepends="cargo protoc"
+makedepends="cargo protoc rustfmt cargo-auditable"
source="$pkgname-$pkgver.tar.gz::https://github.com/paypizza/grpc-health-check/archive/$pkgver.tar.gz"
+
prepare() {
default_prepare
- export PROTOC=/usr/bin/protoc
+ cargo fetch --target="$CTARGET"
}
build() {
- cargo build --release
+ export PROTOC=/usr/bin/protoc
+ cargo auditable build --release --frozen
}
check() {
- cargo test --release
+ export PROTOC=/usr/bin/protoc
+ cargo test --frozen
}
package() {
- make install.bin DESTDIR="$pkgdir/" PREFIX="/usr"
+ install -Dm755 target/release/grpc-health-check -t "$pkgdir"/usr/bin/
}
-sha512sums="5be25efd69a113eada1d773780b38bc2bd0f138286070fc8ab2abe30f181cd4bf302263c1bd576740469851d8168666d421f51d66ef250114aebf9a50c57b039 grpc-health-check-0.1.0.tar.gz"
+sha512sums="
+4f97a0c7399643843f2599799a1b255c7b712c17d115fc7933c042281611250b69bfcd3c0d4c515fcb413eb22ccd6e1644733a6f671c2ad7be8def4e1f695d5b grpc-health-check-0.1.1.tar.gz
+"