aboutsummaryrefslogtreecommitdiffstats
path: root/testing/grype/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/grype/APKBUILD')
-rw-r--r--testing/grype/APKBUILD32
1 files changed, 0 insertions, 32 deletions
diff --git a/testing/grype/APKBUILD b/testing/grype/APKBUILD
deleted file mode 100644
index 04ca4584b1c..00000000000
--- a/testing/grype/APKBUILD
+++ /dev/null
@@ -1,32 +0,0 @@
-# Contributor: Michał Polański <michal@polanski.me>
-# Maintainer: Michał Polański <michal@polanski.me>
-pkgname=grype
-pkgver=0.32.0
-pkgrel=0
-pkgdesc="Vulnerability scanner for container images, filesystems, and SBOMs"
-url="https://github.com/anchore/grype"
-license="Apache-2.0"
-arch="all !armhf !armv7 !x86" # FTBFS on 32-bit arches
-makedepends="go"
-source="https://github.com/anchore/grype/archive/v$pkgver/grype-$pkgver.tar.gz"
-options="!check" # tests need docker
-
-export GOFLAGS="$GOFLAGS -trimpath -mod=readonly -modcacherw"
-export GOPATH="$srcdir"
-export CGO_ENABLED=0
-
-build() {
- go build -o bin/grype
-}
-
-check() {
- go test ./...
-}
-
-package() {
- install -Dm755 bin/grype "$pkgdir"/usr/bin/grype
-}
-
-sha512sums="
-8d22b5e291dea29306094683f939885f9e5fcdc9265d79a838c5f99a6b79acd04f8d8c38dd28123d3b873c7eadf46c9527d7f8e9c9598407565d7d9188f7a1df grype-0.32.0.tar.gz
-"