aboutsummaryrefslogtreecommitdiffstats
path: root/testing/gx-go/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/gx-go/APKBUILD')
-rw-r--r--testing/gx-go/APKBUILD51
1 files changed, 16 insertions, 35 deletions
diff --git a/testing/gx-go/APKBUILD b/testing/gx-go/APKBUILD
index 992d1186529..9df0d782c60 100644
--- a/testing/gx-go/APKBUILD
+++ b/testing/gx-go/APKBUILD
@@ -2,58 +2,39 @@
# Maintainer: Oleg Titov <oleg.titov@gmail.com>
pkgname=gx-go
pkgver=1.9.0
-pkgrel=5
+pkgrel=24
pkgdesc="A tool to use with the gx package manager for packages written in go"
url="https://github.com/whyrusleeping/gx-go"
# riscv64: dependency github.com/minio/sha512-simd does not support riscv64
arch="all !riscv64"
license="MIT"
-options="!check" # Test suite issues
-makedepends="git glide go"
+options="!check net" # Test suite issues
+makedepends="go"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/whyrusleeping/$pkgname/archive/v$pkgver.tar.gz
- glide.yaml
- glide.lock
- "
-builddir="$srcdir/src/github.com/whyrusleeping/$pkgname"
+source="$pkgname-$pkgver.tar.gz::https://github.com/whyrusleeping/gx-go/archive/v$pkgver.tar.gz
+ gomod.patch
+ "
-prepare() {
- export GOPATH="$srcdir"
- export GO111MODULE=off
-
- mkdir -p $(dirname $builddir)
- mv "$srcdir"/$pkgname-$pkgver "$builddir"/
-
- cd "$builddir"
- cp "$srcdir"/glide.yaml "$srcdir"/glide.lock .
- glide install --skip-test
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+prepare() {
default_prepare
+ go mod download
}
build() {
- GOPATH="$srcdir" GOBIN="$GOPATH/bin" make
+ go build -o bin/gx-go
}
package() {
- cd "$srcdir"
install -Dm 755 bin/gx-go "$pkgdir/usr/bin/gx-go"
- cd "$builddir"
install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}
-glide_init() {
- abuild clean deps unpack prepare
- cd "$builddir"
- export GOPATH="$startdir"
- rm -f glide.yaml glide.lock
- glide init --non-interactive
- glide update
- cp glide.yaml glide.lock "$startdir"
- cd "$startdir" && abuild checksum clean
-}
-
-sha512sums="3df8a99d257098afdf99ba6cbf58d50eab196f823ae53db48865a4f4962e38b84a66ffc99d5a342b43ff9891c8245252a77677b75c770d86f93ef1ad3c9e879f gx-go-1.9.0.tar.gz
-db824fce3e8094e2806c68b18ba5b8decae4cb62068113f6bc97f72de1224bd326b3342297739ee9b5a86bd4f7c9ec2f9b04aa3610cc95903dc1b3bfd7b0934f glide.yaml
-32a2ae3e10d20c0ba1613a592d8b9fd7a6e9678e2bc9f262bb6887c22b65c0a8da2c7aef1f70d35b3d89ae6aa6b50ca26cdddd47c3ee274a8ddc1a8bf0b16016 glide.lock"
+sha512sums="
+3df8a99d257098afdf99ba6cbf58d50eab196f823ae53db48865a4f4962e38b84a66ffc99d5a342b43ff9891c8245252a77677b75c770d86f93ef1ad3c9e879f gx-go-1.9.0.tar.gz
+f7678e3ec2092ab9f4a78097dcaa892acb6288bf680c6f992b789d35d241e575d181d53c32e53b19e07ff6c793aed2188b5856c021287b2204eff82c78683e2f gomod.patch
+"