aboutsummaryrefslogtreecommitdiffstats
path: root/testing/h1-cli/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/h1-cli/APKBUILD')
-rw-r--r--testing/h1-cli/APKBUILD36
1 files changed, 0 insertions, 36 deletions
diff --git a/testing/h1-cli/APKBUILD b/testing/h1-cli/APKBUILD
deleted file mode 100644
index 05292847c68..00000000000
--- a/testing/h1-cli/APKBUILD
+++ /dev/null
@@ -1,36 +0,0 @@
-# Contributor: Adam Dobrawy <a.dobrawy@hyperone.com>
-# Maintainer: HyperOne staff <pkg-maintainers@hyperone.com>
-pkgname=h1-cli
-_pkgname=${pkgname/-cli/}
-pkgver=1.8.1
-pkgrel=0
-pkgdesc="Command-line interface for HyperOne platform"
-url="https://www.hyperone.com/tools/cli/"
-arch="x86_64"
-license="MIT"
-depends="openssh-client"
-makedepends="nodejs npm"
-subpackages="rbx-cli:rbx"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hyperonecom/$pkgname/archive/v$pkgver.tar.gz"
-options="!strip !check"
-
-build() {
- npm install
- npx pkg -c ./package.json -t "node12-alpine" -o "./dist/h1" "./bin/h1"
- npx pkg -c ./package.json -t "node12-alpine" -o "./dist/rbx" "./bin/rbx"
-}
-
-package() {
- mkdir -p "$pkgdir"/usr/bin
- cp "$builddir/dist/$_pkgname" "$pkgdir"/usr/bin/$_pkgname
-}
-
-rbx() {
- pkgdesc="Command-line interface for Rootbox platform"
- url="http://rootbox.com/"
- cd "$builddir"
- mkdir -p "$subpkgdir"/usr/bin
- cp "$builddir/dist/rbx" "$subpkgdir"/usr/bin/rbx
-}
-
-sha512sums="f5ce8f53e542e08de9edbaf71229580a86945fd68cbc62e49031e130db53bc664646b2c3384c317cee113972c665f79a3566943ac6b1b96e138c099b897a2500 h1-cli-1.8.1.tar.gz"