aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handbrake/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/handbrake/APKBUILD')
-rw-r--r--testing/handbrake/APKBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/testing/handbrake/APKBUILD b/testing/handbrake/APKBUILD
index e17b6ed6168..1f7b3d395ce 100644
--- a/testing/handbrake/APKBUILD
+++ b/testing/handbrake/APKBUILD
@@ -2,21 +2,19 @@
pkgname=handbrake
_pkgname=HandBrake
pkgver=0.10.2
-pkgrel=0
+pkgrel=1
pkgdesc="Handbrake video transcoder"
url="https://handbrake.fr"
-#pkgusers="$pkgname"
-#pkggroups="$pkgname"
arch="all"
license="GPL2"
install=""
depends=""
-makedepends="yasm autoconf libtool zlib-dev libbz2 libogg-dev libtheora-dev \
- libvorbis-dev libsamplerate-dev fribidi-dev freetype-dev \
- tinyxml-dev fontconfig-dev libass-dev intltool glib-dev dbus-glib-dev \
- gtk+3.0-dev webkitgtk-dev eudev-dev libnotify-dev libdvdread-dev\
+makedepends="yasm autoconf libtool zlib-dev libbz2 libogg-dev libtheora-dev
+ libvorbis-dev libsamplerate-dev fribidi-dev freetype-dev
+ tinyxml-dev fontconfig-dev libass-dev intltool glib-dev dbus-glib-dev
+ gtk+3.0-dev webkitgtk-dev eudev-dev libnotify-dev libdvdread-dev
gstreamer0.10-dev x264-dev lame-dev linux-headers cmake"
-subpackages="$pkgname-gtk"
+subpackages="$pkgname-lang $pkgname-gtk"
source="${_pkgname}-${pkgver}.tar.bz2::https://handbrake.fr/rotation.php?file=${_pkgname}-${pkgver}.tar.bz2"
_builddir="$srcdir"/${_pkgname}-${pkgver}
@@ -24,10 +22,10 @@ _builddir="$srcdir"/${_pkgname}-${pkgver}
build() {
cd "$_builddir"
./configure --prefix=/usr || return 1
-
+
cd build
# This is retarded, but handbrake's "custom.defs" doesn't seem to work
- make ffmpeg.configure
+ make ffmpeg.configure
make ffmpeg.build CFLAGS="-D_GNU_SOURCE -I${_builddir}/build/contrib/include -I."
make build CFLAGS="-I${_builddir}/build/contrib/include -I." || return 1
@@ -35,7 +33,7 @@ build() {
}
package() {
- cd "$_builddir"/build
+ cd "$_builddir"/build
make -j1 install DESTDIR="$pkgdir"
}
@@ -44,11 +42,10 @@ package() {
gtk() {
pkgdesc="HandBrake Video Transcoder - GUI"
install -d "$subpkgdir"/usr/bin
-
+
mv "$pkgdir"/usr/bin/ghb "$subpkgdir"/usr/bin/ghb
mv "$pkgdir"/usr/share "$subpkgdir"/usr
-
}
md5sums="db0a71147463664c4230ed3f1caf4fe8 HandBrake-0.10.2.tar.bz2"