aboutsummaryrefslogtreecommitdiffstats
path: root/testing/handbrake
diff options
context:
space:
mode:
Diffstat (limited to 'testing/handbrake')
-rw-r--r--testing/handbrake/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/handbrake/APKBUILD b/testing/handbrake/APKBUILD
index 3932c501ebc..ed2fcf9b71b 100644
--- a/testing/handbrake/APKBUILD
+++ b/testing/handbrake/APKBUILD
@@ -2,7 +2,7 @@
pkgname=handbrake
_pkgname=HandBrake
pkgver=1.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Handbrake video transcoder"
url="https://handbrake.fr"
arch="x86_64 x86 armhf armv7 ppc64le"
@@ -11,10 +11,10 @@ makedepends="yasm autoconf libtool zlib-dev libbz2 libogg-dev libtheora-dev
libvorbis-dev libsamplerate-dev fribidi-dev freetype-dev
tinyxml-dev fontconfig-dev libass-dev intltool glib-dev dbus-glib-dev
gtk+3.0-dev libgudev-dev libnotify-dev libdvdread-dev
- gstreamer0.10-dev x264-dev lame-dev linux-headers cmake
- autoconf automake ffmpeg-dev coreutils libdvdnav-dev
- libbluray-dev x265-dev libvpx-dev fdk-aac-dev jansson-dev
- opus-dev python2 speex-dev xz-dev"
+ gst-plugins-base-dev x264-dev lame-dev linux-headers cmake
+ automake ffmpeg-dev coreutils libdvdnav-dev libbluray-dev
+ x265-dev libvpx-dev fdk-aac-dev jansson-dev opus-dev python2
+ speex-dev xz-dev"
subpackages="$pkgname-lang $pkgname-gtk"
source="https://download.handbrake.fr/releases/$pkgver/HandBrake-$pkgver-source.tar.bz2
handbrake-9999-fix-missing-x265-link-flag.patch
@@ -26,7 +26,6 @@ options="!check"
builddir="$srcdir"/${_pkgname}-${pkgver}
prepare() {
- cd "$builddir"
default_prepare
# build against external libs
sed -i 's:.*contrib/.*::g' \
@@ -34,7 +33,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--force \