aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hatop/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hatop/APKBUILD')
-rw-r--r--testing/hatop/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/hatop/APKBUILD b/testing/hatop/APKBUILD
new file mode 100644
index 00000000000..558d2cc07af
--- /dev/null
+++ b/testing/hatop/APKBUILD
@@ -0,0 +1,22 @@
+# Contributor: Guy Godfroy <guy.godfroy@gugod.fr>
+# Maintainer: Guy Godfroy <guy.godfroy@gugod.fr>
+pkgname=hatop
+pkgver=0.8.2
+pkgrel=0
+pkgdesc="Interactive ncurses client for HAProxy"
+url="https://github.com/jhunt/hatop"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jhunt/hatop/archive/v$pkgver.tar.gz"
+options="!check" #test script requires docker
+
+package() {
+ install -Dm755 "$builddir"/bin/hatop -t "$pkgdir"/usr/bin/
+ install -Dm644 "$builddir"/man/hatop.1 -t "$pkgdir"/usr/share/man/man1/
+}
+
+sha512sums="
+5e772394d72962bdd014f93ee94ea59814cee33e17c1864af5b3ec97a19c2c33a6ad13f24d0cf0baf78335d9a82cee28b60a03754430b0aa9132c1dd92753cdb hatop-0.8.2.tar.gz
+"