aboutsummaryrefslogtreecommitdiffstats
path: root/testing/helm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/helm/APKBUILD')
-rw-r--r--testing/helm/APKBUILD56
1 files changed, 0 insertions, 56 deletions
diff --git a/testing/helm/APKBUILD b/testing/helm/APKBUILD
deleted file mode 100644
index a546874b44f..00000000000
--- a/testing/helm/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: techknowlogick <techknowlogick@gitea.io>
-# Maintainer: techknowlogick <techknowlogick@gitea.io>
-pkgname=helm
-pkgver=3.6.3
-pkgrel=0
-pkgdesc="The Kubernetes Package Manager"
-url="https://helm.sh/"
-arch="all !mips !mips64 !armhf" # mips does not have go, unit tests fails with armhf
-license="Apache-2.0"
-makedepends="bash go"
-options="net"
-source="$pkgname-$pkgver.tar.gz::https://github.com/helm/helm/archive/v$pkgver.tar.gz"
-
-# secfixes:
-# 3.6.0-r0:
-# - CVE-2021-21303
-# 3.6.1-r0:
-# - CVE-2021-32690
-
-case "$CARCH" in
- # Disable check on 32bit systems due to upstream test "TestPlatformPrepareCommand" that does not account for these platforms
- x86|armv7) options="$options !check" ;;
-esac
-
-export GOPATH="$srcdir/go"
-export GOCACHE="$srcdir/go-build"
-export GOTEMPDIR="$srcdir/go"
-
-export GOFLAGS="$GOFLAGS -modcacherw"
-
-prepare() {
- default_prepare
-
- # Update procfs version for riscv64 support.
- go mod edit -replace \
- github.com/prometheus/procfs=github.com/prometheus/procfs@v0.6.0
- go mod download github.com/prometheus/procfs
- go get k8s.io/apimachinery/pkg/labels@v0.21.0
-}
-
-build() {
- export CGO_ENABLED=0 # breaks on aarch64
- make GOFLAGS="$GOFLAGS"
-}
-
-check() {
- make test-unit GOFLAGS="$GOFLAGS"
-}
-
-package() {
- install -Dm755 bin/helm -t "$pkgdir/usr/bin"
-}
-
-sha512sums="
-675e2bca107eab5955e6b921d12e829045c6b522574eb39a046eca2d1a97b6aa83360832c52904c425d58fa111c001187d95d18073dbda555b38a7679e20511b helm-3.6.3.tar.gz
-"