aboutsummaryrefslogtreecommitdiffstats
path: root/testing/helm/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/helm/APKBUILD')
-rw-r--r--testing/helm/APKBUILD64
1 files changed, 0 insertions, 64 deletions
diff --git a/testing/helm/APKBUILD b/testing/helm/APKBUILD
deleted file mode 100644
index d061b1e1878..00000000000
--- a/testing/helm/APKBUILD
+++ /dev/null
@@ -1,64 +0,0 @@
-# Contributor: techknowlogick <techknowlogick@gitea.io>
-# Maintainer: techknowlogick <techknowlogick@gitea.io>
-pkgname=helm
-pkgver=3.7.1
-pkgrel=0
-pkgdesc="The Kubernetes Package Manager"
-url="https://helm.sh/"
-arch="all !mips !mips64 !armhf" # mips does not have go, unit tests fails with armhf
-license="Apache-2.0"
-makedepends="bash go"
-options="net"
-subpackages="$pkgname-bash-completion $pkgname-fish-completion $pkgname-zsh-completion"
-source="$pkgname-$pkgver.tar.gz::https://github.com/helm/helm/archive/v$pkgver.tar.gz"
-
-# secfixes:
-# 3.6.0-r0:
-# - CVE-2021-21303
-# 3.6.1-r0:
-# - CVE-2021-32690
-
-case "$CARCH" in
- # Disable check on 32bit systems due to upstream test "TestPlatformPrepareCommand" that does not account for these platforms
- x86|armv7) options="$options !check" ;;
-esac
-
-export GOPATH="$srcdir/go"
-export GOCACHE="$srcdir/go-build"
-export GOTEMPDIR="$srcdir/go"
-
-export GOFLAGS="$GOFLAGS -modcacherw"
-
-prepare() {
- default_prepare
-
- # Update procfs version for riscv64 support.
- go mod edit -replace \
- github.com/prometheus/procfs=github.com/prometheus/procfs@v0.6.0
- go mod download github.com/prometheus/procfs
-}
-
-build() {
- export CGO_ENABLED=0 # breaks on aarch64
- make GOFLAGS="$GOFLAGS"
-
- ./bin/helm completion bash > $pkgname.bash
- ./bin/helm completion fish > $pkgname.fish
- ./bin/helm completion zsh > $pkgname.zsh
-}
-
-check() {
- make test-unit GOFLAGS="$GOFLAGS"
-}
-
-package() {
- install -Dm755 bin/helm -t "$pkgdir/usr/bin"
-
- install -Dm644 $pkgname.bash "$pkgdir"/usr/share/bash-completion/completions/$pkgname
- install -Dm644 $pkgname.fish "$pkgdir"/usr/share/fish/completions/$pkgname.fish
- install -Dm644 $pkgname.zsh "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
-}
-
-sha512sums="
-60122fc14914549c3e8c328182c7902ab04dbb30d57d67ce864755fd332d8e2ce8f43ba579f72348697fba8bdb0e1b74b60da605c228e6ee431d17ce3fdbc872 helm-3.7.1.tar.gz
-"