aboutsummaryrefslogtreecommitdiffstats
path: root/testing/helmfile/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/helmfile/APKBUILD')
-rw-r--r--testing/helmfile/APKBUILD44
1 files changed, 34 insertions, 10 deletions
diff --git a/testing/helmfile/APKBUILD b/testing/helmfile/APKBUILD
index 77e29d3a450..f0b454e7d5b 100644
--- a/testing/helmfile/APKBUILD
+++ b/testing/helmfile/APKBUILD
@@ -1,38 +1,62 @@
# Contributor: Hoang Nguyen <folliekazetani@protonmail.com>
# Maintainer: Hoang Nguyen <folliekazetani@protonmail.com>
pkgname=helmfile
-pkgver=0.145.0
-pkgrel=0
+pkgver=0.162.0
+pkgrel=2
pkgdesc="Declarative spec for deploying helm charts"
url="https://helmfile.readthedocs.io/"
-arch="all !armhf" # blocked by helm
+# armhf: ftbfs
+arch="all !armhf"
license="MIT"
depends="helm"
makedepends="go"
checkdepends="bash"
subpackages="
+ $pkgname-doc
$pkgname-bash-completion
$pkgname-zsh-completion
+ $pkgname-fish-completion
"
source="$pkgname-$pkgver.tar.gz::https://github.com/helmfile/helmfile/archive/refs/tags/v$pkgver.tar.gz"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
build() {
- go build -v -o $pkgname -ldflags "-X github.com/helmfile/helmfile/pkg/app/version.Version=v$pkgver"
+ local _goldflags="
+ -X go.szostok.io/version.version=$pkgver
+ -X go.szostok.io/version.buildDate=$(date -u "+%Y-%m-%dT%H:%M:%S%z" ${SOURCE_DATE_EPOCH:+-d @$SOURCE_DATE_EPOCH})
+ -X go.szostok.io/version.commitDate=$(date -u "+%Y-%m-%dT%H:%M:%S%z" ${SOURCE_DATE_EPOCH:+-d @$SOURCE_DATE_EPOCH})
+ -X go.szostok.io/version.commit=0000000
+ -X go.szostok.io/version.dirtyBuild=false
+ -X github.com/helmfile/helmfile/pkg/runtime.v1Mode=true
+ "
+ go build -v -o helmfile -ldflags "$_goldflags"
+
+ for shell in bash fish zsh; do
+ ./helmfile completion $shell > $pkgname.$shell
+ done
}
check() {
- go test ./...
+ # e2e/template test requires docker
+ # shellcheck disable=2046
+ go test $(go list ./... | grep -v /e2e)
}
package() {
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
- install -Dm644 autocomplete/helmfile_bash_autocomplete \
- "$pkgdir"/usr/share/bash-completion/completions/$pkgname
- install -Dm644 autocomplete/helmfile_zsh_autocomplete \
- "$pkgdir"/usr/share/zsh/site-functions/_$pkgname
+ install -Dm644 helmfile.bash \
+ "$pkgdir"/usr/share/bash-completion/completions/helmfile
+ install -Dm644 helmfile.zsh \
+ "$pkgdir"/usr/share/zsh/site-functions/_helmfile
+ install -Dm644 helmfile.fish \
+ "$pkgdir"/usr/share/fish/vendor_completions.d/helmfile.fish
}
sha512sums="
-725065aa5fc54f82904a138fdb1a8c93832855d32d174ddf0693899b908979f18633d01a417a37b6bf90c065e5a670d4d696a419b2bfb83a9701521ae2a9229f helmfile-0.145.0.tar.gz
+54c114c4f1deb090e7e6b198469629c783de7638b315972320b35ba53bae95d31d18df6ee3b28ed1bca1f2eba2d6e75dd64dc45ebf4d60af9cf4281b14ab2e91 helmfile-0.162.0.tar.gz
"