aboutsummaryrefslogtreecommitdiffstats
path: root/testing/helvum/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/helvum/APKBUILD')
-rw-r--r--testing/helvum/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/testing/helvum/APKBUILD b/testing/helvum/APKBUILD
index 9ec10d2b2fb..836b316733c 100644
--- a/testing/helvum/APKBUILD
+++ b/testing/helvum/APKBUILD
@@ -1,20 +1,22 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Michał Polański <michal@polanski.me>
pkgname=helvum
-pkgver=0.3.1
-pkgrel=1
+pkgver=0.5.1
+pkgrel=0
pkgdesc="GTK patchbay for pipewire"
-url="https://gitlab.freedesktop.org/ryuukyu/helvum"
-license="GPL-3.0"
-arch="all !s390x !mips64 !riscv64" # blocked by rust/cargo
+url="https://gitlab.freedesktop.org/pipewire/helvum"
+license="GPL-3.0-only"
+arch="all !s390x !riscv64" # blocked by rust/cargo
arch="$arch !x86 !armv7 !armhf" # FTBFS on 32-bit systems
-makedepends="cargo meson clang-dev glib-dev gtk4.0-dev pipewire-dev"
-source="https://gitlab.freedesktop.org/ryuukyu/helvum/-/archive/$pkgver/helvum-$pkgver.tar.gz"
+makedepends="bash cargo desktop-file-utils meson clang-dev glib-dev gtk4.0-dev pipewire-dev libadwaita-dev"
+source="https://gitlab.freedesktop.org/pipewire/helvum/-/archive/$pkgver/helvum-$pkgver.tar.gz
+ pipewire-rs-0.7.2.patch
+ "
options="!check" # no test suite
build() {
abuild-meson . output
- meson compile ${JOBS:+-j ${JOBS}} -C output
+ meson compile -C output
}
package() {
@@ -22,5 +24,6 @@ package() {
}
sha512sums="
-6a8bafb6302d2638e76d22f348bba1ca222857d5dde42f178853151bf50161574e1a534d7194decab4677651d152ac38dcefa3cfde28ea8630ca0360c3b88868 helvum-0.3.1.tar.gz
+7d4655a32d0c35c4bcc4164f8bc08654be08613d488a12ec237ef7757242ebd3ca6bc944eb757a234080187eec2c9b558bdba228e8e1a9d9e670c1620f5bb4d1 helvum-0.5.1.tar.gz
+7b2701c5e7f8a195ad3bdb68de3881becfdcc4c11db3de9e16acf4828a159389c34ba8fbdd9918b9474d0df51a7f8d0a7a449b1976dea0fddc007feb9e9372fa pipewire-rs-0.7.2.patch
"