aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hiawatha/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hiawatha/APKBUILD')
-rw-r--r--testing/hiawatha/APKBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/testing/hiawatha/APKBUILD b/testing/hiawatha/APKBUILD
index babd7187f56..e3d7c35ee9b 100644
--- a/testing/hiawatha/APKBUILD
+++ b/testing/hiawatha/APKBUILD
@@ -2,17 +2,17 @@
# Contributor: Pascal Ernster <aur at hardfalcon dot net>
# Contributor: Stuart Cardall <developer at it-offshore dot co.uk>
pkgname=hiawatha
-pkgver=10.12
-pkgrel=1
-_php=php8
+pkgver=11.5
+pkgrel=0
+_php=php81
pkgdesc='Secure and advanced webserver'
-url='https://www.hiawatha-webserver.org/'
+url='https://hiawatha.leisink.net/'
arch="all"
license='GPL-2.0-only'
options="suid !check"
subpackages="$pkgname-doc $pkgname-openrc $pkgname-letsencrypt::noarch"
makedepends="cmake libxml2-dev libxslt-dev mbedtls-dev"
-source="https://hiawatha-webserver.org/files/hiawatha-10/hiawatha-$pkgver.tar.gz
+source="https://hiawatha.leisink.net/files/hiawatha-$pkgver.tar.gz
hiawatha.initd
hiawatha.conf.sample
letsencrypt.helper
@@ -50,9 +50,10 @@ letsencrypt() {
depends="$_php $_php-openssl"
pkgdesc="PHP scripts to generate SSL certificates with letsencrypt"
- mkdir -p "$subpkgdir"/usr/sbin "$subpkgdir"/usr/share/man/man1
+ mkdir -p "$subpkgdir"/usr/sbin "$subpkgdir"/usr/share/man/man1 "$subpkgdir"/usr/lib/hiawatha
mv "$pkgdir"-doc/usr/share/man/man1/lefh.1.gz "$subpkgdir"/usr/share/man/man1/
- mv "$pkgdir"/usr/lib "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/lib/hiawatha/letsencrypt "$subpkgdir"/usr/lib/hiawatha
+ rmdir -p "$pkgdir"/usr/lib/hiawatha || true
mv "$pkgdir"/usr/sbin/lefh "$subpkgdir"/usr/sbin/
mkdir -p "$subpkgdir"/usr/lib/hiawatha/letsencrypt/scripts
install -Dm750 "$builddir"/extra/letsencrypt/scripts/* "$subpkgdir"/usr/lib/hiawatha/letsencrypt/scripts/
@@ -60,8 +61,8 @@ letsencrypt() {
}
sha512sums="
-3b4866140e3073fdd4226a96362e7c29ab72f1d4a2b689ee1cd36e915f1aaa7e933bad453a2b236057c9fbfb3c5384b6b35589e59e85fdde38730e932ef045f8 hiawatha-10.12.tar.gz
+575013567488b76bf37734a882e6608378a236f4f8cce7bb35a3949c97b894c1efa5963ab589f59fe27e6e1ba06ff0490f0c7bf7cfc87cd77bd5b60ca85a4bb6 hiawatha-11.5.tar.gz
cec0adfb48e1751cf13031f2c28f4590340b2c747aa8e81d18c16bc8789bce69b2d9d99290a93b74b501db3b63190a071033a78abeeb8f60becba2dcaf3b5c40 hiawatha.initd
771bed17b5831bb9d4a28eb94482dd39de8c4b5b35b2c08e1c303a2778254f9e34e40a8d791cc7ef4e73740f474c502685252378e7fe2cba494c782c11f960d4 hiawatha.conf.sample
-704d4968feb0cbc9bc3fcd76a52c43efb708d89048349ea2daf2313bea1034c4b88a73a9473d6a012759e82ad8167408257b6dd3d266ae9eedef541255ba0ab6 letsencrypt.helper
+dbdd0cdf975b226d2ac27257861a1cc6c1f77c8387d632014368a1c835817a33b780f446cd3fdb7d9ca4322eaede1fea28652dde70928cc8a73f0b05dba46f6e letsencrypt.helper
"