aboutsummaryrefslogtreecommitdiffstats
path: root/testing/highway/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/highway/APKBUILD')
-rw-r--r--testing/highway/APKBUILD41
1 files changed, 0 insertions, 41 deletions
diff --git a/testing/highway/APKBUILD b/testing/highway/APKBUILD
deleted file mode 100644
index 2876ad5fc37..00000000000
--- a/testing/highway/APKBUILD
+++ /dev/null
@@ -1,41 +0,0 @@
-# Maintainer: Alex Xu (Hello71) <alex_y_xu@yahoo.ca>
-pkgname=highway
-pkgver=0.15.0
-pkgrel=0
-pkgdesc="Performance-portable, length-agnostic SIMD with runtime dispatch"
-url="https://github.com/google/highway"
-arch="all"
-license="Apache-2.0"
-makedepends="gtest-dev"
-subpackages="$pkgname-dev"
-source="highway-$pkgver.tar.gz::https://github.com/google/highway/archive/refs/tags/$pkgver.tar.gz
- fix-riscv64-build.patch"
-
-# https://github.com/google/highway/issues/398
-if [ "$CARCH" = aarch64 ]; then
- options="!check"
-fi
-
-build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_TESTING=ON \
- -DHWY_SYSTEM_GTEST=ON
- cmake --build build
-}
-
-check() {
- cd build
- : ${CTEST_PARALLEL_LEVEL=$JOBS}
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
-}
-
-package() {
- DESTDIR="$pkgdir" cmake --install build
-}
-
-sha512sums="
-ed07e855721f87ea67d762b30e001643a76bd16d70372415023c8e6f1a43c58759a14a638e8eb20566863d8358d994153bf7a660fcf604e808adfea5f938a013 highway-0.15.0.tar.gz
-c039edd9167026f79418d2a4091d3e838d378cdd3b1d6ce742b97064f56b8eac443549f14b8466add355e08e2ed4455d22e404d749191f245dc960ea22f960aa fix-riscv64-build.patch
-"