aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hledger-ui/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hledger-ui/APKBUILD')
-rw-r--r--testing/hledger-ui/APKBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/testing/hledger-ui/APKBUILD b/testing/hledger-ui/APKBUILD
deleted file mode 100644
index dfa7d154ab0..00000000000
--- a/testing/hledger-ui/APKBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-# Contributor: Dhruvin Gandhi <contact@dhruvin.dev>
-# Maintainer: Dhruvin Gandhi <contact@dhruvin.dev>
-pkgname=hledger-ui
-pkgver=1.24.1
-pkgrel=0
-pkgdesc="Curses-style terminal interface for the hledger accounting system"
-url="https://hledger.org/hledger-ui.html"
-arch="x86_64" # limited by ghc
-license="GPL-3.0-only"
-makedepends="ghc cabal libffi-dev ncurses-dev"
-subpackages="$pkgname-doc"
-source="https://hackage.haskell.org/package/hledger-ui-$pkgver/hledger-ui-$pkgver.tar.gz
- cabal.project.freeze"
-
-export CABAL_DIR="$srcdir"/cabal
-
-prepare() {
- default_prepare
- cp "$srcdir"/cabal.project.freeze .
-}
-
-build() {
- cabal update
- cabal build --prefix=/usr --enable-relocatable
-}
-
-check() {
- cabal test
-}
-
-package() {
- local ghcver=$(ghc --version | cut -d " " -f 8)
- install -Dm755 \
- "dist-newstyle/build/$arch-linux/ghc-$ghcver/$pkgname-$pkgver/x/$pkgname/build/$pkgname/$pkgname" \
- "$pkgdir"/usr/bin/$pkgname
- install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
-}
-
-sha512sums="
-9a71ba18c76a477a12df34adb4d1d11e5a72769b14e27950ff675107faf210dbe9ee18d4e6bf13151789f73591e72b62fb7f3ea581a2ddff6457814d9220f4d4 hledger-ui-1.24.1.tar.gz
-a8c9d31b82ad69cf0ad7324186f3f9b49ee7400b8eb450ce8fa6f99da28c138982bf16b1f1d20bf9ef7380509ea273d1e913d8d0e87192aba69154891aeab1bc cabal.project.freeze
-"