aboutsummaryrefslogtreecommitdiffstats
path: root/testing/homebank/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/homebank/APKBUILD')
-rw-r--r--testing/homebank/APKBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/testing/homebank/APKBUILD b/testing/homebank/APKBUILD
index ea4eeeffe91..44f1ee82717 100644
--- a/testing/homebank/APKBUILD
+++ b/testing/homebank/APKBUILD
@@ -1,19 +1,22 @@
# Contributor: 7heo <7heo@mail.com>
-# Maintainer: 7heo <7heo@mail.com>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=homebank
-pkgver=5.4.3
+pkgver=5.7.4
pkgrel=0
pkgdesc="Free personal finance software, money management"
url="http://homebank.free.fr"
arch="all"
license="GPL-2.0-or-later"
-makedepends="bash gtk+3.0-dev libsoup-dev libofx-dev intltool"
+makedepends="gtk+3.0-dev libsoup3-dev libofx-dev intltool"
options="!check" # no test suite
subpackages="$pkgname-lang"
-source="http://homebank.free.fr/public/homebank-$pkgver.tar.gz"
+source="http://homebank.free.fr/public/sources/homebank-$pkgver.tar.gz"
build() {
- ./configure --prefix=/usr
+ ./configure \
+ --host=$CHOST \
+ --build=$CBUILD \
+ --prefix=/usr
make
}
@@ -21,4 +24,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="e2b3b45a6d35205c3d2bf24d4c0c065889fa4e7d92cc9551db873b8b33cc15e6c1dd721936b438db0725509233bf265446b0512e23973cbebae7af4a7dce96ba homebank-5.4.3.tar.gz"
+sha512sums="
+d65127b49a7566f5ad88feb8c614883c43e322ea50d915e49691b169771fac222573da4988ab1c54d9f39b9dfdf2d724cba07269e093c67a04900828d0b87093 homebank-5.7.4.tar.gz
+"