aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hplip/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hplip/APKBUILD')
-rw-r--r--testing/hplip/APKBUILD65
1 files changed, 34 insertions, 31 deletions
diff --git a/testing/hplip/APKBUILD b/testing/hplip/APKBUILD
index 73e08433731..3f5a0b72ebf 100644
--- a/testing/hplip/APKBUILD
+++ b/testing/hplip/APKBUILD
@@ -3,37 +3,29 @@
# Contributor: Timo Teräs <timo.teras@iki.fi>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=hplip
-pkgver=3.19.12
-pkgrel=0
+pkgver=3.23.12
+pkgrel=2
pkgdesc="Drivers for HP printers and scanners"
-arch="x86 x86_64" # missing sane on several arches
-url="http://hplipopensource.com"
-license="GPL"
-makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev gawk python3-dev
- autoconf automake libtool"
-subpackages="$pkgname-doc $pkgname-libs sane-backend-hpaio:sane"
+arch="all"
+url="https://hplipopensource.com/"
+license="GPL-2.0-only AND BSD-3-Clause AND MIT"
+makedepends="dbus-dev libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev gawk python3-dev py3-setuptools"
+subpackages="$pkgname-doc $pkgname-libs $pkgname-ppd sane-backend-hpaio:sane"
source="https://downloads.sourceforge.net/hplip/hplip-$pkgver.tar.gz
- fix-includes.patch
- types-musl.patch
+ fix-memmove.patch
disable_upgrade.patch
- 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
- python-3.8-compat.patch
+ more-imageprocessor-removes.patch
+ no-empty-glob.patch
+ types-musl.patch
"
-prepare() {
- default_prepare
- update_config_guess
- touch NEWS README AUTHORS ChangeLog
- autoreconf -vif
-}
-
build() {
./configure --prefix=/usr \
--with-docdir=/usr/share/doc/$pkgname \
--disable-doc-build \
--disable-gui-build \
--disable-fax-build \
- --disable-dbus-build \
+ --disable-imageProcessor-build \
--enable-cups-drv-install \
--enable-cups-ppd-install
make
@@ -45,18 +37,27 @@ check() {
package() {
make -j1 DESTDIR="$pkgdir" install
- rm -fr "$pkgdir"/usr/bin \
- "$pkgdir"/etc/udev \
- "$pkgdir"/etc/sane.d \
- "$pkgdir"/usr/share/hal \
- "$pkgdir"/usr/lib/systemd \
- "$pkgdir"/usr/lib/cups/filter/pstotiff
install -m755 -D prnt/filters/hpps "$pkgdir"/usr/lib/cups/filter/hpps
+
+ cd "$pkgdir"
+ rm -fr usr/bin \
+ etc/udev \
+ etc/sane.d \
+ usr/share/hal \
+ usr/lib/systemd \
+ usr/lib/cups/filter/pstotiff
+}
+
+ppd() {
+ pkgdesc="$pkgdesc (PPD files)"
+ mkdir -p "$subpkgdir"/usr/share/ppd/
+ mv "$pkgdir"/usr/share/ppd/HP "$subpkgdir"/usr/share/ppd/
}
sane() {
depends="sane"
pkgdesc="SANE backend for HP multi-function peripherals"
+ install_if="sane-backends"
provides="$pkgname-sane"
mkdir -p "$subpkgdir"/usr/lib \
"$subpkgdir"/etc/sane.d/dll.d
@@ -64,9 +65,11 @@ sane() {
echo "hpaio" > "$subpkgdir"/etc/sane.d/dll.d/hpaio
}
-sha512sums="5552cd717ae082ee55cdb77d79e8d035d8ecb7cf23c79d659fda43468d8ed414a33c4d869eab4ab83dee836f0d1cceb74c3c4a249e26f904a5ab2350e08a5677 hplip-3.19.12.tar.gz
-173f0c2bbf0daefc717282bf125d3fd94b3914da0754078c45b58b09ab841672aae9238ca8fc0448486a871e40fc50f960da17c1e07ad3f04053d217ed634498 fix-includes.patch
-dbce7d859661b1a03847edf91db755c9b3d1ad7c2d3173741ecd89b954d1595d71f1adcbd481e81821ebd58cd9ae23adcef1cc026cfa09928fb0cba599781cd1 types-musl.patch
+sha512sums="
+7461ffec38be68421e4204021f53d2b1641e7a67c14f205390d45f487a1af90956fd221f7e1561635508103ae944f19e04d6052d3f8928f2c9685fdcdcf515df hplip-3.23.12.tar.gz
+7d247b219595a8be4a9d709f14a9034eee1cef467981ffc29d18ee3c00bee125640b1149d7e57e3332242efd978d7cb3f8f25f21d41fb39e38f9520626cfe1ff fix-memmove.patch
ac436b54aecc0c2a7fc0eb5ae8e28d483c1efd5bd9385b0a1480fb78b8ccdd28ef85db86a980aec5ca093e9095d5714f93df095bf606e9a9c919f07c64e29697 disable_upgrade.patch
-0ededf7b27abab1b2f889f19bb3587816d437ed1b8253a68e9e4af99684456057c1529b353c439e11b2235cb84560e90bb841d348fa53b49e4bbc123a41aba81 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
-33e034c99d67535326fb2361d2f9c4a70b38ddd0b64b5e6edaf8d6ac3d786fdc9ef35295a5aed53abbf6953998e7260954b3372df66dad310729c71cea201091 python-3.8-compat.patch"
+d8e76cb3757a7659f667e3d54cd0b7572dd8af1f4f87e26694dd3e4b1e0ec5cba7fe2d0ca531e14d568a675aa4a201795a3edb2c8892230e41e0d9408959b726 more-imageprocessor-removes.patch
+69442c4bd2410e69a0d6314ce5db6b4638dd6a08c817b749f7b74e8e98db90eccb05ad3b44b71278e83cc3bbf6009fee8818855c1f08df9d6d8d5a35a078d68e no-empty-glob.patch
+dbce7d859661b1a03847edf91db755c9b3d1ad7c2d3173741ecd89b954d1595d71f1adcbd481e81821ebd58cd9ae23adcef1cc026cfa09928fb0cba599781cd1 types-musl.patch
+"