aboutsummaryrefslogtreecommitdiffstats
path: root/testing/htslib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/htslib/APKBUILD')
-rw-r--r--testing/htslib/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/htslib/APKBUILD b/testing/htslib/APKBUILD
new file mode 100644
index 00000000000..8af6f3ca9bb
--- /dev/null
+++ b/testing/htslib/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Grigory Kirillov <txgk@bk.ru>
+# Maintainer:
+pkgname=htslib
+pkgver=1.19
+pkgrel=0
+pkgdesc="C library for high-throughput sequencing data formats"
+url="https://github.com/samtools/htslib"
+arch="all"
+license="MIT AND BSD-3-Clause-Modification"
+options="!check" # no test suite
+makedepends="
+ bzip2-dev
+ curl-dev
+ libdeflate-dev
+ xz-dev
+ zlib-dev
+ "
+source="https://github.com/samtools/htslib/releases/download/$pkgver/htslib-$pkgver.tar.bz2"
+subpackages="
+ $pkgname-static
+ $pkgname-dev
+ $pkgname-tools:_tools
+ $pkgname-doc
+ "
+
+build() {
+ ./configure \
+ --target="$CTARGET" \
+ --build="$CBUILD" \
+ --host="$CHOST" \
+ --prefix=/usr \
+ --enable-libcurl \
+ --with-libdeflate \
+ --with-plugin-dir=/usr/lib/htslib/plugins
+ make
+}
+
+_tools() {
+ pkgdesc="Utilities for high-throughput sequencing data formats"
+ amove usr/bin
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+0001a5aba59bf655470fc3e0444b1b51575391f2b47e50bb66d0722407bfba744611ceaf8405450c4a630d506a583ef42e46bfa0842b2a95ea48cb359164f26a htslib-1.19.tar.bz2
+"