aboutsummaryrefslogtreecommitdiffstats
path: root/testing/httpie-oauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/httpie-oauth/APKBUILD')
-rw-r--r--testing/httpie-oauth/APKBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/testing/httpie-oauth/APKBUILD b/testing/httpie-oauth/APKBUILD
index 5b6ef89eeef..c9d343e2ab3 100644
--- a/testing/httpie-oauth/APKBUILD
+++ b/testing/httpie-oauth/APKBUILD
@@ -2,21 +2,25 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=httpie-oauth
pkgver=1.0.2
-pkgrel=4
+pkgrel=8
pkgdesc="OAuth plugin for HTTPie"
-url="https://github.com/jkbr/httpie-oauth"
+url="https://github.com/httpie/httpie-oauth"
arch="noarch"
license="BSD-3-Clause"
depends="python3 httpie py3-requests-oauthlib"
-makedepends="py3-setuptools"
+makedepends="py3-setuptools py3-gpep517 py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/h/httpie-oauth/httpie-oauth-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ gpep517 install-wheel --destdir "$pkgdir" \
+ .dist/*.whl
}
sha512sums="d2825143e839f82591db59995619f7437fccc42e9f126ca247e19b1533706cfaadaab5c3518d3d994e898fcb3d98ed899cd9a36f07963d701eb019587c2821c6 httpie-oauth-1.0.2.tar.gz"