aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hub/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hub/APKBUILD')
-rw-r--r--testing/hub/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/hub/APKBUILD b/testing/hub/APKBUILD
index c600650cb86..1cb05f6c88e 100644
--- a/testing/hub/APKBUILD
+++ b/testing/hub/APKBUILD
@@ -4,7 +4,7 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=hub
pkgver=2.14.2
-pkgrel=3
+pkgrel=21
pkgdesc="Extends git with extra features for GitHub"
url="https://hub.github.com/"
arch="all"
@@ -21,6 +21,10 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/github/hub/archive/v$pkgver.
builddir="$srcdir/src/github.com/github/hub"
+export GOCACHE="${GOCACHE:-"$srcdir/go-cache"}"
+export GOTMPDIR="${GOTMPDIR:-"$srcdir"}"
+export GOMODCACHE="${GOMODCACHE:-"$srcdir/go"}"
+
prepare() {
mkdir -p "${builddir%/*}"
mv $pkgname-$pkgver "$builddir"
@@ -44,7 +48,7 @@ package() {
install -Dm644 "$builddir"/etc/$pkgname.zsh_completion \
"$pkgdir"/usr/share/zsh/site-functions/_$pkgname
install -Dm644 "$builddir"/etc/$pkgname.fish_completion \
- "$pkgdir"/usr/share/fish/completions/$pkgname.fish
+ "$pkgdir"/usr/share/fish/vendor_completions.d/$pkgname.fish
}
sha512sums="4809d12966cc983f42c8aef482e07bc4226e25fc4deba838e418664ce14ac9d2ac42842d0721a46466a80c0e492392542ecfaaccc2cea0efdd60df8b60a3ca02 hub-2.14.2.tar.gz"