aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/hy/APKBUILD')
-rw-r--r--testing/hy/APKBUILD40
1 files changed, 21 insertions, 19 deletions
diff --git a/testing/hy/APKBUILD b/testing/hy/APKBUILD
index d386c9fe34e..25634328c82 100644
--- a/testing/hy/APKBUILD
+++ b/testing/hy/APKBUILD
@@ -1,46 +1,48 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=hy
-pkgver=1.0_p3
-_realver=${pkgver%_p*}a${pkgver##*_p}
-pkgrel=1
+pkgver=0.28.0
+pkgrel=0
pkgdesc="Dialect of Lisp that's embedded in Python"
url="http://hylang.org/"
arch="noarch"
license="MIT"
-# XXX: py3-astor can be removed with python3 >= 3.10
-depends="python3 py3-funcparserlib py3-astor py3-rply py3-colorama"
-makedepends="py3-setuptools py3-sphinx py3-sphinxcontrib-hydomain py3-sphinx_rtd_theme"
+depends="python3 py3-funcparserlib py3-rply py3-colorama"
+makedepends="py3-setuptools py3-sphinx py3-sphinxcontrib-hydomain py3-sphinx_rtd_theme py3-wheel"
checkdepends="python3-tests py3-pytest py3-pytest-runner py3-tox"
-subpackages="$pkgname-doc"
options="net"
-source="$pkgname-$pkgver.tar.gz::https://github.com/hylang/hy/archive/$_realver.tar.gz"
-builddir="$srcdir/$pkgname-$_realver"
+subpackages="$pkgname-pyc"
+#subpackages="$pkgname-doc $pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hylang/hy/archive/$pkgver.tar.gz"
# By default setup.py tries to determine the hy version using
# git-describe(1). Unfourtunatly, this will return the version
# of the aports repository on Alpine.
-export HY_VERSION="$_realver"
+export HY_VERSION="$pkgver"
build() {
python3 setup.py build
- make -C docs/ man
+
+ # TODO: Building the documentation requires py3-sphinx >= 7.X.
+ #cd docs
+ #sphinx-build . _build -b man
}
check() {
# Ignore tests requiring binaries to be installed
- py.test-3 --ignore tests/test_bin.py \
+ pytest --ignore tests/test_bin.py \
--ignore tests/test_hy2py.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
- local man
- for man in docs/_build/man/*.?; do
- install -Dm644 "$man" \
- "$pkgdir"/usr/share/man/man${man##*.}/${man##*/}
- done
+ # XXX: See comment regarding documentation above.
+ # local man
+ # for man in docs/_build/*.?; do
+ # install -Dm644 "$man" \
+ # "$pkgdir"/usr/share/man/man${man##*.}/${man##*/}
+ # done
# This file is only needed for setuptools-produced source
# distributions <https://github.com/hylang/hy/commit/bd7b8bf5e19e>.
@@ -48,5 +50,5 @@ package() {
}
sha512sums="
-eb4aa876b58ba75d338aede036f6834616809e2da7a1d9aae4f0c803dcf290de4846bcdf844ca673885adce2518cebcfdf60f58840d4853ea3ff76c591cd1ed9 hy-1.0_p3.tar.gz
+71873e7f8d000f0febd6e8c48870d2a4bfeaab7f842b88194b7373c9926c6bfe59a217814b96bd4f2ec0103c5070b31128b0a794874db7aed5f2f329b224f25a hy-0.28.0.tar.gz
"