aboutsummaryrefslogtreecommitdiffstats
path: root/testing/icdiff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/icdiff/APKBUILD')
-rw-r--r--testing/icdiff/APKBUILD40
1 files changed, 0 insertions, 40 deletions
diff --git a/testing/icdiff/APKBUILD b/testing/icdiff/APKBUILD
deleted file mode 100644
index e225d910f21..00000000000
--- a/testing/icdiff/APKBUILD
+++ /dev/null
@@ -1,40 +0,0 @@
-# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
-# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
-pkgname=icdiff
-pkgver=2.0.4
-pkgrel=0
-pkgdesc="Improved colored diff"
-url="https://www.jefftk.com/icdiff"
-arch="noarch"
-license="Python-2.0"
-depends="python3"
-makedepends="py3-setuptools bash"
-checkdepends="py3-flake8"
-source="https://github.com/jeffkaufman/icdiff/archive/release-$pkgver.tar.gz
- fix-flake8-binary.patch
- "
-builddir="$srcdir/icdiff-release-$pkgver"
-
-prepare() {
- default_prepare
-
- # patch removes executable bit
- chmod +x test.sh icdiff
-}
-
-build() {
- python3 setup.py build
-}
-
-check() {
- ./test.sh python3
-}
-
-package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
-}
-
-sha512sums="
-ec600a3f7b1e23516fe9b239b4ddc714c196f78552755b8a8e1ce898e6f93a1079ecca051c86520d0b3429a764dfb50cc4e6ab96418cf7c5ea6921c316d84973 release-2.0.4.tar.gz
-fc6fa3c98b245a9ce1830428c1d59b37f75faaab00dbf44a6d78f84318cfb4bf3fdc826fc86b9ca8a9efbd2a760223525270ea79e4d761e64d4a18597693eb64 fix-flake8-binary.patch
-"