aboutsummaryrefslogtreecommitdiffstats
path: root/testing/idesk/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/idesk/APKBUILD')
-rw-r--r--testing/idesk/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/idesk/APKBUILD b/testing/idesk/APKBUILD
new file mode 100644
index 00000000000..ebe43551ffd
--- /dev/null
+++ b/testing/idesk/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
+pkgname=idesk
+pkgver=1
+pkgrel=0
+pkgdesc="Program to show icons on the desktop"
+url="http://idesk.sourceforge.net/html/index.html"
+arch="all"
+license="GPL-2.0-only"
+makedepends="texinfo automake autoconf imlib2-dev libxft-dev"
+source="https://github.com/antonialoytorrens/idesk/releases/download/v$pkgver/idesk-v$pkgver.tar.gz"
+builddir="$srcdir/idesk-v$pkgver"
+
+build() {
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3190fca7a5c9fb36b66159107d22b5f6e50b4573afa21a3a4d8b8e3e5953dabda077c924e45d2607b849ee5fea141eb80f5b89ce5288ebc2490679f319edf768 idesk-v1.tar.gz"