aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ideviceinstaller/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/ideviceinstaller/APKBUILD')
-rw-r--r--testing/ideviceinstaller/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/ideviceinstaller/APKBUILD b/testing/ideviceinstaller/APKBUILD
new file mode 100644
index 00000000000..bbe488f6380
--- /dev/null
+++ b/testing/ideviceinstaller/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Kasper K <kasperkantz@outlook.com>
+# Maintainer: Kasper K <kasperkantz@outlook.com>
+pkgname=ideviceinstaller
+pkgver=1.1.1
+pkgrel=3
+pkgdesc="Manage apps of iOS devices"
+url="https://libimobiledevice.org"
+arch="all"
+license="LGPL-2.1-or-later"
+makedepends="libimobiledevice-dev libzip-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/libimobiledevice/ideviceinstaller/releases/download/$pkgver/ideviceinstaller-$pkgver.tar.bz2"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+fd117a5745890746237f381c9fe0e01cf8ea06d9c2341da397c52e5ebc0e058c73797e349a0a81b2777f5333dafc32e5c32e9e2c99ee70a864be159fe73e9568 ideviceinstaller-1.1.1.tar.bz2
+"