aboutsummaryrefslogtreecommitdiffstats
path: root/testing/idris2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/idris2/APKBUILD')
-rw-r--r--testing/idris2/APKBUILD55
1 files changed, 0 insertions, 55 deletions
diff --git a/testing/idris2/APKBUILD b/testing/idris2/APKBUILD
deleted file mode 100644
index 9bad8ec6a84..00000000000
--- a/testing/idris2/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer:
-pkgname=idris2
-pkgver=0.5.1
-pkgrel=0
-pkgdesc="Purely functional programming language with first class types"
-url="https://www.idris-lang.org"
-arch="x86 x86_64" # limited by chez-scheme
-license="BSD-3-Clause"
-depends="chez-scheme gmp-dev"
-makedepends="bash py3-sphinx py3-sphinx_rtd_theme"
-subpackages="$pkgname-doc"
-source="https://github.com/idris-lang/Idris2/archive/v$pkgver/idris2-$pkgver.tar.gz"
-builddir="$srcdir/Idris2-$pkgver"
-
-case "$CARCH" in
-x86) options="!check" ;; # XXX: https://github.com/idris-lang/Idris2/issues/1617
-esac
-
-# TODO: Install idris libs to /usr/lib/idris-$pkgver instead of /usr/idris-$pkgver
-# TODO: Self-hosting step (maybe split into idris2 and idris2-bootstrap?)
-# TODO: Install the Idris 2 API (make install-api)
-
-# TODO: https://github.com/idris-lang/Idris2/issues/737
-# TODO: https://github.com/idris-lang/Idris2/pull/1123
-
-build() {
- # Bootstrap Idris 2 compiler from scheme sources.
- make -j1 bootstrap PREFIX=/usr SCHEME=chez
-
- # Create HTML documentation.
- make -C docs html
-}
-
-check() {
- make -j1 bootstrap-test
-}
-
-package() {
- # Idris2 Makefile doesn't honor ${DESTDIR}
- # See https://github.com/idris-lang/Idris2/pull/1123
- make IDRIS2_PREFIX="$pkgdir/usr" \
- PREFIX="$pkgdir/usr" install
-
- # Install additional documentation files
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
- install -m644 CHANGELOG.md CONTRIBUTING.md \
- CONTRIBUTORS README.md "$pkgdir"/usr/share/doc/$pkgname/
- cp -r docs/build/html "$pkgdir"/usr/share/doc/$pkgname/
- # TODO: Use install-libdocs
-}
-
-sha512sums="
-6b4a4092570136a684bdd80765d271bc1ebe163c273ff22d22c808f586183a8e90a326573dd0e4b339e1ab0b88fd31f1cc7bf2820ff7bab2742c4156b816c5b7 idris2-0.5.1.tar.gz
-"