aboutsummaryrefslogtreecommitdiffstats
path: root/testing/igt-gpu-tools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/igt-gpu-tools/APKBUILD')
-rw-r--r--testing/igt-gpu-tools/APKBUILD58
1 files changed, 41 insertions, 17 deletions
diff --git a/testing/igt-gpu-tools/APKBUILD b/testing/igt-gpu-tools/APKBUILD
index b663408ed2d..69841caf8a3 100644
--- a/testing/igt-gpu-tools/APKBUILD
+++ b/testing/igt-gpu-tools/APKBUILD
@@ -1,37 +1,61 @@
# Contributor: Dennis Krupenik <dennis@krupenik.com>
# Maintainer: Dennis Krupenik <dennis@krupenik.com>
pkgname=igt-gpu-tools
-pkgver=1.25
-pkgrel=0
-pkgdesc="IGT GPU Tools is a collection of tools for development and testing of the DRM drivers."
+pkgver=1.27.1
+pkgrel=1
+pkgdesc="collection of tools for development and testing of the DRM drivers"
url="https://gitlab.freedesktop.org/drm/igt-gpu-tools/"
-arch="x86_64" # Mostly used for Intel integrated GPUs
+arch="x86_64" # intel gpus, aarch64 fails to build
license="MIT"
-depends_dev="alsa-lib-dev cairo-dev curl-dev elfutils-dev eudev-dev gsl-dev
- json-c-dev kmod-dev libdrm-dev liboping-dev libpciaccess-dev libunwind-dev
- libxrandr-dev libxv-dev pixman-dev procps-dev xmlrpc-c-dev"
-makedepends="bison flex meson $depends_dev"
+depends_dev="
+ alsa-lib-dev
+ cairo-dev
+ curl-dev
+ elfutils-dev
+ eudev-dev
+ gsl-dev
+ json-c-dev
+ kmod-dev
+ libdrm-dev
+ liboping-dev
+ libpciaccess-dev
+ libunwind-dev
+ libxrandr-dev
+ libxv-dev
+ pixman-dev
+ procps-compat-dev
+ xmlrpc-c-dev
+ "
+makedepends="
+ $depends_dev
+ bison
+ flex
+ meson
+ "
+checkdepends="bash"
subpackages="$pkgname-dev"
-source="https://gitlab.freedesktop.org/drm/igt-gpu-tools/-/archive/igt-gpu-tools-$pkgver/igt-gpu-tools-igt-gpu-tools-$pkgver.tar.bz2
- bash-sh.patch
- musl.patch"
-builddir="$srcdir/igt-gpu-tools-igt-gpu-tools-$pkgver"
+source="https://gitlab.freedesktop.org/drm/igt-gpu-tools/-/archive/v$pkgver/igt-gpu-tools-v$pkgver.tar.gz
+ musl.patch
+ "
+builddir="$srcdir/igt-gpu-tools-v$pkgver"
build() {
abuild-meson \
-Dvalgrind=disabled \
+ -Dversion_hash=$pkgver \
. build
- meson compile ${JOBS:+-j ${JOBS}} -C build
+ meson compile -C build
}
check() {
- meson test --no-rebuild -v -C build
+ meson test --no-rebuild --print-errorlogs -C build
}
package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C build
}
-sha512sums="47a31c0af733e9481e3e8e718adede0a05cb04064d80dae6a7753a346deb71333fb8310664084f4dddfec957629e93c188bc44f2a6895744a10107e4823a9ee6 igt-gpu-tools-igt-gpu-tools-1.25.tar.bz2
-0e24d93cdc56517c78fbcdc64dac63067c9cf49bed66e3b2b6dec6111d67c7e27a2ad7ddb9f1e373746b4b8e9e3535993f8261800fc3729d1f2cdef37e392fc5 bash-sh.patch
-a79a3d4134a75e450b18188189614ad0b3d4218007c8ce68c74f5a928258ca8838ccce5c1f64f920038c44e188896d8d504a36e3cbdf1f8f16c3904bb3b9955f musl.patch"
+sha512sums="
+b77d28f95098e4c51678a0a73ad755a5dd28748c77cf8e8c4f46f6d65444939032d2d0ed3c637e4968682d72a5d8cbabd7b8f47737f7fa279b02667fd4ddae9b igt-gpu-tools-v1.27.1.tar.gz
+f372d8e60519c6d9d72efd32d87fc9851eace59cf7c0b66dc5f8795dcfb9efd4aae5f316cd52396ebaba9e0c338f166f1d4ccf828ea473276ea6ed07f71fae32 musl.patch
+"