aboutsummaryrefslogtreecommitdiffstats
path: root/testing/iozone/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/iozone/APKBUILD')
-rw-r--r--testing/iozone/APKBUILD49
1 files changed, 0 insertions, 49 deletions
diff --git a/testing/iozone/APKBUILD b/testing/iozone/APKBUILD
deleted file mode 100644
index 1fdc9cf1ffb..00000000000
--- a/testing/iozone/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Contributor: Oleg Titov <oleg.titov@gmail.com>
-# Maintainer: Oleg Titov <oleg.titov@gmail.com>
-pkgname=iozone
-pkgver=3.490
-_pkgver=${pkgver//./_}
-pkgrel=1
-pkgdesc="IOzone filesystem benchmark."
-url="http://iozone.org"
-arch="all !mips !mips64 !riscv64"
-license="custom"
-options="!check" # No test suite from upstream
-subpackages="$pkgname-doc"
-source="http://iozone.org/src/current/iozone$_pkgver.tar
- https://www.iozone.org/docs/Iozone_License.txt
- "
-builddir="$srcdir/${pkgname}$_pkgver/"
-
-build() {
- local target=
- case "$CARCH" in
- x86_64) target="linux-AMD64" ;;
- x86) target="linux" ;;
- aarch64) target="linux-arm" ;;
- armv7) target="linux-arm" ;;
- armhf) target="linux-arm" ;;
- s390x) target="linux-S390X" ;;
- ppc64le) target="linux-powerpc64" ;;
- *) msg "Unable to determine architecture from (CARCH=$CARCH)" ; return 1 ;;
- esac
-
- cd "$builddir"/src/current/
- make $target CFLAGS='-DHAVE_PREADV -DHAVE_PWRITEV'
-}
-
-package() {
- install -m755 -D src/current/iozone \
- "$pkgdir"/usr/bin/iozone
-
- install -Dm644 "$srcdir"/Iozone_License.txt \
- "$pkgdir"/usr/share/licenses/$pkgname/Iozone_License.txt
-
- install -Dm644 "$builddir"/docs/iozone.1 \
- "$pkgdir"/usr/share/man/man1/iozone.1
-}
-
-sha512sums="
-15959cdb0a1f94cbe0063c72666683a5c2d8221dba04c7548ca96ac0ac5edf6118ccd54f1d4fd55151dbad79fc886bdd440a409b7906b4f6c0465c1f770fbcc6 iozone3_490.tar
-9589952c15cde6701f239b6031996e504fd62f70ef1e63938544ca8ecf7e38b53ff731919e48285a9354080120b74fcdd9d548ada9a719368726e67b536e6fda Iozone_License.txt
-"