aboutsummaryrefslogtreecommitdiffstats
path: root/testing/irclog2html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/irclog2html/APKBUILD')
-rw-r--r--testing/irclog2html/APKBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/testing/irclog2html/APKBUILD b/testing/irclog2html/APKBUILD
index 9354a464389..6b3912fefc5 100644
--- a/testing/irclog2html/APKBUILD
+++ b/testing/irclog2html/APKBUILD
@@ -1,26 +1,35 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=irclog2html
-pkgver=2.17.3
-pkgrel=0
+pkgver=3.0.0
+pkgrel=2
pkgdesc="Script to convert IRC logs to HTML and other formats"
url="https://mg.pov.lt/irclog2html/"
arch="noarch"
license="GPL-2.0-or-later"
-depends="python3"
-makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/i/irclog2html/irclog2html-$pkgver.tar.gz"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-mock py3-pytest py3-zope-testing"
+subpackages="$pkgname-pyc"
+source="https://github.com/mgedmin/irclog2html/archive/refs/tags/$pkgver/irclog2html-$pkgver.tar.gz"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
install -Dpm 0644 src/$pkgname/irclog.css \
"$pkgdir"/usr/share/$pkgname/irclog.css
}
sha512sums="
-2fce4bf10494e3bf3d71f425c363716b0db846ac40aeec7ef274e4344e36302ddd027b0922804a457c269f67f895e87d1b4e9d0e1dba60ca6f1f4b3e52500bff irclog2html-2.17.3.tar.gz
+8924be06058c92f772c07156bf696d00f5ad6814d2b5a5e84469b166a3690a0b98847b28aefc5545f3bda21822fadf693bb599867572e53b481ea8e2a0e9143e irclog2html-3.0.0.tar.gz
"