aboutsummaryrefslogtreecommitdiffstats
path: root/testing/isomd5sum/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/isomd5sum/APKBUILD')
-rw-r--r--testing/isomd5sum/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/isomd5sum/APKBUILD b/testing/isomd5sum/APKBUILD
new file mode 100644
index 00000000000..067d82119ad
--- /dev/null
+++ b/testing/isomd5sum/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Hossein Hosni <hosni.hossein@gmail.com>
+# Maintainer: Hossein Hosni <hosni.hossein@gmail.com>
+pkgname=isomd5sum
+pkgver=1.2.3
+pkgrel=2
+pkgdesc="Utilities for working with md5sum implanted in ISO images"
+url="https://github.com/rhinstaller/isomd5sum"
+arch="all !armv7 !armhf"
+license="GPL-2.0-only"
+makedepends="python3-dev popt-dev"
+checkdepends="cdrkit"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/rhinstaller/isomd5sum/archive/refs/tags/$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+check() {
+ # create 100KB dummy file to include in testiso.iso
+ dd if=/dev/urandom of=dummy-file.bin bs=1 count=102400
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install-bin install-python
+}
+
+sha512sums="
+a500faa368377c8fb5dfc311bc3a6dbadd253e6af7928b691d1fc11e25b69819a611f72fa201e70f5df257cdc491c97d1f612bb179fa49de1fb0a638d6ac7972 isomd5sum-1.2.3.tar.gz
+"