aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jdupes/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/jdupes/APKBUILD')
-rw-r--r--testing/jdupes/APKBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/testing/jdupes/APKBUILD b/testing/jdupes/APKBUILD
index 7d8afb3a970..ae235f39850 100644
--- a/testing/jdupes/APKBUILD
+++ b/testing/jdupes/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: tcely <tcely@users.noreply.github.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=jdupes
-pkgver=1.15.0
+pkgver=1.27.3
pkgrel=0
pkgdesc="identifying and taking actions upon duplicate files"
options="!check" # No testsuite
@@ -9,14 +9,20 @@ url="https://github.com/jbruchon/jdupes"
arch="all"
license="MIT"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/jbruchon/jdupes/archive/v$pkgver.tar.gz"
+makedepends="linux-headers libjodycode-dev xxhash-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jbruchon/jdupes/archive/v$pkgver.tar.gz
+ system-xxhash.patch
+ "
build() {
- make
+ make ENABLE_DEDUPE=1
}
package() {
make DESTDIR="$pkgdir" PREFIX=/usr install
}
-sha512sums="690fcc69bacc4bde1d352871e3f4a843d4dbf038bd7755343f9fd0cb2a4c72bffa7223719435e39a32e79a25b0f315023c5f76b251015e1887451653f7198e3b jdupes-1.15.0.tar.gz"
+sha512sums="
+634ce1d1efa4666c7cc968e99d8d8d7da5e80e6e0ed86a080088ab127b7ecc4cc5266305d8a5c3d9c524721a2adc99c700281aa3dba37efade3cc1b90df1544e jdupes-1.27.3.tar.gz
+6c8430b76fba6cf4458d1a8e3f0c431250a59029a18cfc38f4befe23a94da25153cb1e54eb4b6de3c66a8015ca1c083c46d2cf215f594317c48eed580078ba6b system-xxhash.patch
+"