aboutsummaryrefslogtreecommitdiffstats
path: root/testing/jhead/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/jhead/APKBUILD')
-rw-r--r--testing/jhead/APKBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/testing/jhead/APKBUILD b/testing/jhead/APKBUILD
index 89e6870e5dc..2ea4b41b5b3 100644
--- a/testing/jhead/APKBUILD
+++ b/testing/jhead/APKBUILD
@@ -1,30 +1,36 @@
# Contributor: Richard Mortier <mort@cantab.net>
# Maintainer: Richard Mortier <mort@cantab.net>
pkgname=jhead
-pkgver=3.04
+pkgver=3.08
pkgrel=0
pkgdesc="Exif Jpeg header manipulation tool"
url="http://www.sentex.net/~mwandel/jhead/"
arch="all"
license="custom"
subpackages="$pkgname-doc"
-source="http://www.sentex.net/~mwandel/jhead/jhead-$pkgver.tar.gz"
-options="!check" # no test suite
+source="$pkgname-$pkgver.tar.gz::https://github.com/Matthias-Wandel/jhead/archive/refs/tags/$pkgver.tar.gz"
+options="!check" # fixme: failing tests
+
+# secfixes:
+# 3.06.0.1-r0:
+# - CVE-2020-6624
+# - CVE-2020-6625
build() {
make all
}
-package() {
- install -Dm755 jhead "$pkgdir"/usr/bin/jhead
+check() {
+ cd tests
+ ./runtests
+ diff expected-txt results-txt
}
-doc() {
- cd "$builddir"
- gzip -v9 jhead.1
- install -Dm644 jhead.1.gz "$subpkgdir"/usr/share/man/man1/jhead.1.gz
- install -Dm644 readme.txt \
- "$subpkgdir"/usr/share/licenses/$pkgname/readme.txt
+package() {
+ install -Dm755 jhead "$pkgdir"/usr/bin/jhead
+ install -Dm644 jhead.1 -t "$pkgdir"/usr/share/man/man1/
}
-sha512sums="d783b02059ebcb01845d346e7c48bdc9d9f12fb7b0fd47bf8aff0a85a03f3523fbc536ddab0912f1c56ddb315b6cf31f16d4c7a4f81112d9a4c76a4a57ec1aed jhead-3.04.tar.gz"
+sha512sums="
+eb50e487eaacf2b489ce5e76f09730c8bb0c50a0e2d7c854ebe8bd204ead8f6256e052c49c72af179dc46dd5372c1eff32ff549b947637b242dc7bbe8c7b20d5 jhead-3.08.tar.gz
+"