aboutsummaryrefslogtreecommitdiffstats
path: root/testing/json-c0.12/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/json-c0.12/APKBUILD')
-rw-r--r--testing/json-c0.12/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/json-c0.12/APKBUILD b/testing/json-c0.12/APKBUILD
new file mode 100644
index 00000000000..ced8d7bace7
--- /dev/null
+++ b/testing/json-c0.12/APKBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=json-c0.12
+pkgver=0.12.1
+pkgrel=2
+pkgdesc="A JSON implementation in C"
+url="https://github.com/json-c/json-c/wiki"
+arch="all"
+license="MIT"
+makedepends=" autoconf automake libtool"
+subpackages="$pkgname-dev"
+replaces="json-c"
+source="https://s3.amazonaws.com/json-c_releases/releases/json-c-$pkgver.tar.gz
+ "
+
+builddir="$srcdir"/json-c-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -f -v -i
+}
+
+build() {
+ export CFLAGS="$CFLAGS -Wno-error=unused-but-set-variable -Wno-error=implicit-fallthrough"
+ ./configure --prefix=/usr \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-shared \
+ --disable-static \
+ ac_cv_func_malloc_0_nonnull=yes \
+ ac_cv_func_realloc_0_nonnull=yes
+ make -j1
+}
+
+check() {
+ make USE_VALGRIND=0 check
+}
+
+package() {
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+sha512sums="038676a0ce815e5174161fbd4339524feadc294d517f732fb408ad6aa7c4906423451c13386107569d9f24746a1a101564ca511e92e8276c5bf5b8c022ca42ed json-c-0.12.1.tar.gz"