aboutsummaryrefslogtreecommitdiffstats
path: root/testing/junit2html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/junit2html/APKBUILD')
-rw-r--r--testing/junit2html/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/junit2html/APKBUILD b/testing/junit2html/APKBUILD
new file mode 100644
index 00000000000..0b409bc8163
--- /dev/null
+++ b/testing/junit2html/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Charles Wimmer <charles@wimmer.net>
+# Maintainer: Charles Wimmer <charles@wimmer.net>
+pkgname=junit2html
+pkgver=0.2.0
+pkgrel=3
+pkgdesc="Simple self-contained python tool to produce a single html file from a single junit xml file"
+url="https://gitlab.com/inorton/junit2html"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+builddir="$srcdir/$pkgname-v$pkgver"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/inorton/junit2html/-/archive/v$pkgver/junit2html-v$pkgver.tar.gz
+ setup.py.patch
+ "
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+85902808752d299c9dd94e9158f4913b74f3b8c0639eb52a4ec32cc27774ef096072a3e18560a809f20a7c9ccc8d8ce8b107d6b6fd3d4e68ed51fbe2d90ce344 junit2html-0.2.0.tar.gz
+c3b5a80d3ff23cbf4391d4822ee841b216ec60bc9463d84b1c017a247295145ccdfa821a990dbf26c473e6055f7ef4b364f847628fb897a03d905d7ad0a7540b setup.py.patch
+"