aboutsummaryrefslogtreecommitdiffstats
path: root/testing/junit2html/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/junit2html/APKBUILD')
-rw-r--r--testing/junit2html/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/testing/junit2html/APKBUILD b/testing/junit2html/APKBUILD
index a860ccab00b..0b409bc8163 100644
--- a/testing/junit2html/APKBUILD
+++ b/testing/junit2html/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Charles Wimmer <charles@wimmer.net>
# Maintainer: Charles Wimmer <charles@wimmer.net>
pkgname=junit2html
-pkgver=0.1.0
-pkgrel=1
+pkgver=0.2.0
+pkgrel=3
pkgdesc="Simple self-contained python tool to produce a single html file from a single junit xml file"
url="https://gitlab.com/inorton/junit2html"
arch="noarch"
@@ -10,6 +10,7 @@ license="MIT"
depends="python3"
makedepends="py3-setuptools"
builddir="$srcdir/$pkgname-v$pkgver"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://gitlab.com/inorton/junit2html/-/archive/v$pkgver/junit2html-v$pkgver.tar.gz
setup.py.patch
"
@@ -23,8 +24,10 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="4603b78cc950656df73c89b211cee030783435afc771b53715d677c1a47d5cc0d280e2f2eadec2e6382dbad3d7b88ff9ea3ce4d5b5a0bf6d216d7485659952b2 junit2html-0.1.0.tar.gz
-c3b5a80d3ff23cbf4391d4822ee841b216ec60bc9463d84b1c017a247295145ccdfa821a990dbf26c473e6055f7ef4b364f847628fb897a03d905d7ad0a7540b setup.py.patch"
+sha512sums="
+85902808752d299c9dd94e9158f4913b74f3b8c0639eb52a4ec32cc27774ef096072a3e18560a809f20a7c9ccc8d8ce8b107d6b6fd3d4e68ed51fbe2d90ce344 junit2html-0.2.0.tar.gz
+c3b5a80d3ff23cbf4391d4822ee841b216ec60bc9463d84b1c017a247295145ccdfa821a990dbf26c473e6055f7ef4b364f847628fb897a03d905d7ad0a7540b setup.py.patch
+"