aboutsummaryrefslogtreecommitdiffstats
path: root/testing/justc-envdir/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/justc-envdir/APKBUILD')
-rw-r--r--testing/justc-envdir/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/justc-envdir/APKBUILD b/testing/justc-envdir/APKBUILD
new file mode 100644
index 00000000000..68c2dde6402
--- /dev/null
+++ b/testing/justc-envdir/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jürgen Brunink <oss@jbserver.eu>
+# Contributor: Jürgen Brunink <oss@jbserver.eu>
+pkgname=justc-envdir
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Fork of s6-envdir that reads entire files."
+url="https://github.com/just-containers/$pkgname/"
+arch="all"
+license="ISC"
+makedepends="skalibs-dev"
+options="!check" # no test suite/unit tests
+source="https://github.com/just-containers/justc-envdir/releases/download/v$pkgver/justc-envdir-$pkgver.tar.gz"
+
+
+build() {
+ ./configure \
+ --enable-shared \
+ --disable-allstatic \
+ --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ rm -r "$pkgdir"/usr/include
+}
+
+sha512sums="0cf1383073f289f6275595912105dde907fddfc2d9a39789a4ae0b4e11e3eb67b0b760f95aa9e32beca6b80a0b70d335761de06c867918a3a9e31883256db343 justc-envdir-1.0.0.tar.gz"