aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kak-lsp/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kak-lsp/APKBUILD')
-rw-r--r--testing/kak-lsp/APKBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/testing/kak-lsp/APKBUILD b/testing/kak-lsp/APKBUILD
index 2e737dd829b..d7e9016388b 100644
--- a/testing/kak-lsp/APKBUILD
+++ b/testing/kak-lsp/APKBUILD
@@ -1,25 +1,34 @@
# Contributor: Siva Mahadevan <me@svmhdvn.name>
# Maintainer: Siva Mahadevan <me@svmhdvn.name>
pkgname=kak-lsp
-pkgver=9.0.0
+pkgver=15.0.1
pkgrel=0
pkgdesc="Language Server Protocol client for Kakoune implemented in Rust"
url="https://github.com/kak-lsp/kak-lsp"
-arch="all !s390x !mips !mips64 !ppc64le !riscv64" # limited by cargo
+arch="all !s390x !riscv64" # limited by cargo
license="Unlicense OR MIT"
-makedepends="cargo"
+makedepends="cargo cargo-auditable"
source="$pkgname-$pkgver.tar.gz::https://github.com/kak-lsp/kak-lsp/archive/v$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+
+ cargo fetch --target="$CTARGET" --locked
+}
+
build() {
- cargo build --locked --release
+ cargo auditable build --frozen --release
}
check() {
- cargo test --locked
+ cargo test --frozen
}
package() {
install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
}
-sha512sums="141accf23bed1d2fc561237cfabb7b0fc944165b2ace760d193b5ae8fc123ed0d3d93ea43dd111ea0539fdf6967711fd627a4ffb79b508e926bc6e4e97090b3f kak-lsp-9.0.0.tar.gz"
+sha512sums="
+46e3d054e30be698a58b23fa5818cc29ebee6ddacdd7189af23a2faa20151bde779bd556034d668f50127ee0cd023b5ad6582c4fedfd22b6d7e40fa0dd928b13 kak-lsp-15.0.1.tar.gz
+"