aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kbackup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kbackup/APKBUILD')
-rw-r--r--testing/kbackup/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/testing/kbackup/APKBUILD b/testing/kbackup/APKBUILD
index 2c3f8cfbef9..9f4a9e16d8e 100644
--- a/testing/kbackup/APKBUILD
+++ b/testing/kbackup/APKBUILD
@@ -1,31 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kbackup
-pkgver=19.12.2
-pkgrel=1
+pkgver=19.12.3
+pkgrel=0
arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kbackup"
pkgdesc="An application which lets you back up your data in a simple, user friendly way"
-license="GPL-2.0-or-only"
+license="GPL-2.0-only"
makedepends="extra-cmake-modules qt5-qtbase-dev knotifications-dev ki18n-dev kio-dev kdoctools-dev kxmlgui-dev kiconthemes-dev karchive-dev kwidgetsaddons-dev shared-mime-info"
-source="https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kbackup-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
options="!check" # No tests
build() {
- cmake \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
- make
+ make -C build
}
check() {
+ cd build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" make -C build install
}
-sha512sums="a783307a70c2ac74d944d334db6597561dff9aa29dbdee7e7820d783b896523a3018a826001b311eaa007f6a5f7648ce97754df3b4dea3dc2a91330d1fad9669 kbackup-19.12.2.tar.xz"
+sha512sums="09f8b7ae80fb87fa3340e455414c5d6bd9e70e7414754f3e628c0b9b26e49f5c664fab018b9c1d06343ecc567643697075311572f5215ac413dc6b778c7346bc kbackup-19.12.3.tar.xz"