aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kde-dev-scripts/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kde-dev-scripts/APKBUILD')
-rw-r--r--testing/kde-dev-scripts/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/kde-dev-scripts/APKBUILD b/testing/kde-dev-scripts/APKBUILD
new file mode 100644
index 00000000000..aef5583fe5d
--- /dev/null
+++ b/testing/kde-dev-scripts/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=kde-dev-scripts
+pkgver=19.04.3
+pkgrel=0
+arch="all"
+url="https://kde.org/applications/development/"
+pkgdesc="Scripts and setting files useful during development of KDE software"
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules kdoctools-dev"
+source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc"
+options="!check" # No code to test
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="a74c6a9366950de6a610de9bca9eef2deb119e2dda48b406ce4c8d49c046a4710a481eaf41033914b8809d6e96e8961eba6d3772bf1de4943435090160839524 kde-dev-scripts-19.04.3.tar.xz"