aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kexec-tools
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kexec-tools')
-rw-r--r--testing/kexec-tools/APKBUILD9
-rw-r--r--testing/kexec-tools/aarch64-build-fix.patch12
2 files changed, 17 insertions, 4 deletions
diff --git a/testing/kexec-tools/APKBUILD b/testing/kexec-tools/APKBUILD
index 56e67d8ff88..558b12fa1e2 100644
--- a/testing/kexec-tools/APKBUILD
+++ b/testing/kexec-tools/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Duncan Guthrie <dguthrie@posteo.net>
pkgname=kexec-tools
pkgver=2.0.16
-pkgrel=0
+pkgrel=1
pkgdesc="Directly boot into a new kernel over a currently running one"
url="https://kernel.org/pub/linux/utils/kernel/kexec/"
arch="all"
@@ -11,13 +11,13 @@ depends="xz zlib"
makedepends="zlib-dev xz-dev linux-headers"
subpackages="$pkgname-doc"
source="https://www.kernel.org/pub/linux/utils/kernel/kexec/$pkgname-$pkgver.tar.xz
- kexec-tools-2.0.16-fix-config-sub.patch"
+ kexec-tools-2.0.16-fix-config-sub.patch
+ aarch64-build-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
options="!check"
build() {
cd "$builddir"
-
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,4 +36,5 @@ package() {
}
sha512sums="f2f06e7702fef20c8d7d6aabe1b264e2e2689e5c38cc00dbc2186dd7fa0479edb2dc9e307dd2ad7f03db47015e966e577f11576172604ef01c1bcca471fe2c24 kexec-tools-2.0.16.tar.xz
-3c87540309dceda4c074d5822fd1a5d709ad533baed91dfd77aa64ebfe3850fc099c4b3d2bcc887c81ae53dc5940d17ccf34be25609beb37ed5ef7ed75862d43 kexec-tools-2.0.16-fix-config-sub.patch"
+3c87540309dceda4c074d5822fd1a5d709ad533baed91dfd77aa64ebfe3850fc099c4b3d2bcc887c81ae53dc5940d17ccf34be25609beb37ed5ef7ed75862d43 kexec-tools-2.0.16-fix-config-sub.patch
+77c2c33c28b85640646836da1709e898e1d94b92e0a83217664c64cb6606e10471235a396f30f8cae1315d67804851fc9cf8f201bc0b9e1d1f1f8344cd0e448d aarch64-build-fix.patch"
diff --git a/testing/kexec-tools/aarch64-build-fix.patch b/testing/kexec-tools/aarch64-build-fix.patch
new file mode 100644
index 00000000000..5f9f9157255
--- /dev/null
+++ b/testing/kexec-tools/aarch64-build-fix.patch
@@ -0,0 +1,12 @@
+diff --git a/purgatory/arch/arm64/Makefile b/purgatory/arch/arm64/Makefile
+index 636abea..9aad157 100644
+--- a/purgatory/arch/arm64/Makefile
++++ b/purgatory/arch/arm64/Makefile
+@@ -3,6 +3,7 @@ arm64_PURGATORY_EXTRA_CFLAGS = \
+ -mcmodel=large \
+ -fno-stack-protector \
+ -fno-asynchronous-unwind-tables \
++ -fno-PIC \
+ -Wundef \
+ -Werror-implicit-function-declaration \
+ -Wdeclaration-after-statement \