aboutsummaryrefslogtreecommitdiffstats
path: root/testing/keystone/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/keystone/APKBUILD')
-rw-r--r--testing/keystone/APKBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/testing/keystone/APKBUILD b/testing/keystone/APKBUILD
index b790a638875..fd79ad90237 100644
--- a/testing/keystone/APKBUILD
+++ b/testing/keystone/APKBUILD
@@ -2,13 +2,13 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=keystone
pkgver=0.9.2
-pkgrel=2
+pkgrel=6
pkgdesc="Keystone assembler framework: Core (Arm, Arm64, Hexagon, Mips, PowerPC, Sparc, SystemZ & X86) + bindings"
url="https://www.keystone-engine.org/"
arch="all !riscv64" # weird cmake + autoconf hybrid system is weird and hates riscv
license="custom"
makedepends="cmake python3-dev py3-setuptools"
-subpackages="$pkgname-dev $pkgname-python"
+subpackages="$pkgname-dev $pkgname-python-pyc $pkgname-python"
source="$pkgname-$pkgver.tar.gz::https://github.com/keystone-engine/keystone/archive/$pkgver.tar.gz"
prepare() {
@@ -35,7 +35,7 @@ package() {
make -C build-shared DESTDIR="$pkgdir" install
cd "$builddir"/bindings/python
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
python() {
@@ -44,4 +44,6 @@ python() {
amove usr/lib/python3*
}
-sha512sums="5d4dd30410410bc7848e75a2e31e8ecef6241ad25e21963aa7a07bbea21d95b75e235c80573129014102684c9647710ace3c0776a8401844d7e4b45cab7bd04b keystone-0.9.2.tar.gz"
+sha512sums="
+5d4dd30410410bc7848e75a2e31e8ecef6241ad25e21963aa7a07bbea21d95b75e235c80573129014102684c9647710ace3c0776a8401844d7e4b45cab7bd04b keystone-0.9.2.tar.gz
+"