aboutsummaryrefslogtreecommitdiffstats
path: root/testing/kimchi/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/kimchi/APKBUILD')
-rw-r--r--testing/kimchi/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/kimchi/APKBUILD b/testing/kimchi/APKBUILD
index 1fad258c156..9dd0eb48c06 100644
--- a/testing/kimchi/APKBUILD
+++ b/testing/kimchi/APKBUILD
@@ -2,11 +2,11 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=kimchi
pkgver=3.0.0
-pkgrel=1
+pkgrel=7
pkgdesc="An HTML5 management interface for KVM"
url="https://github.com/kimchi-project/kimchi"
-arch="noarch !mips64 !s390x !riscv64" # blocked by wok and others
-license="Apache-2.0 and LGPL-2.1-or-later"
+arch="noarch !s390x !riscv64" # blocked by wok and others
+license="Apache-2.0 AND LGPL-2.1-or-later"
depends="
gingerbase
libvirt-daemon
@@ -26,7 +26,6 @@ depends="
py3-pillow
py3-psutil
py3-simplejson
- py3-six
py3-yaml
python3
qemu
@@ -47,19 +46,17 @@ makedepends="
libxslt
py3-cherrypy
py3-mock
- py3-pip
py3-pyflakes
py3-pytest
- py3-requests
py3-setuptools
python3-dev
- spice-html5
"
+checkdepends="py3-requests"
options="!check" # depends on jaraco
-subpackages="$pkgname-lang"
+subpackages="$pkgname-lang $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/kimchi/archive/$pkgver.tar.gz"
-build() {
+build() {
sh ./autogen.sh --system
./configure \
--prefix=/usr \
@@ -77,4 +74,6 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="0a10a4eb5a08d3bb9e16e9388031a1f01623aa150a66abcb7e25abac065151979777bfdc880ed9c200b028649766234776a64336c2a2e3a67f0d858d0afcda66 kimchi-3.0.0.tar.gz"
+sha512sums="
+0a10a4eb5a08d3bb9e16e9388031a1f01623aa150a66abcb7e25abac065151979777bfdc880ed9c200b028649766234776a64336c2a2e3a67f0d858d0afcda66 kimchi-3.0.0.tar.gz
+"